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2nd Sheets using Office 2010 and MicroStation V8 
General Information 
Instructions in this document are for development of 2nd sheets using Office 2010 and 
MicroStation V8 2004 or MicroStation V8i. Image captures of MicroStation V8i are 
shown but application is the same in MicroStation V8 2004.  

The process of attaching Office files in MicroStation is called ‘OLE linking’, which 
stands for Object Link and Embed.  

It works best to Link Excel files and to Embed Word files when users are attaching 
Office files to MicroStation V8. CADD Support has embedded several Word documents 
in MicroStation V8 DGN seed files including General Notes and Index sheets in order to 
streamline their production.  

Some examples of 2nd Sheets created using Word and Excel: 
ROADWAY INDEX AND STANDARD DRAWINGS INDEX  1A  Embedded Word 

PROJECT COMMITMENTS 1B Linked Excel 

ESTIMATED BRIDGE QUANTITIES AND BRIDGE INDEX  2        Linked Excel & Embedded Word 

ESTIMATED ROADWAY QUANTITIES 2A Linked Excel 

ESTIMATED UTILITIES QUANTITIES 2B Linked Excel 

GENERAL NOTES AND SPECIAL NOTES 2G  Embedded Word 

TABULATED QUANTITIES 2H - 2J Linked Excel 

PROPERTY MAPS AND RIGHT-OF-WAY ACQUISITION  
TABLES 3, 3A - 3B Linked Excel  

PHASING NOTES 36, 36A Embedded Word 

UTILITIES INDEX, UTILITY OWNERS, AND UTILITY  
SHEETS U1-1 Embedded Word 

‘Embedded’ Word documents are available only from inside the MicroStation file.  

‘Linked’ Excel files are external to MicroStation and can be opened & edited from either 
inside MicroStation or outside of MicroStation directly in Excel. If the Office file is 
edited separate from MicroStation, the link in MicroStation must be updated after the 
MicroStation file is opened in order to reflect the current information.  

The Office OLE attachment is a picture of the Office file. The boundary of the picture is 
defined by a MicroStation shape element. The OLE attachment can be modified by 
graphics commands such as move, copy and scale. 
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Set up Office 2010 
This is the recommended set up for Office 2010 when using the T.D.O.T. Design 
Division templates and programs. If Office templates are not installed to the default 
folders, then the directions will need to be modified accordingly. 

Do this one time only when using Word and Excel 2010 for the first time with the 
TDOT templates and programs. This must be done for each user profile that will be using 
Office 2010 to link with MicroStation V8. 

Word: 
1. In Word 2010, click on the File tab at the far left of the ribbon and choose Options 

from the drop down list. 
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2. In the Word Options dialog click on Save in the options on the left.  

Set the Save Files in this format: option to Word Document (*.docx). 
Use the Browse button to the right of Default File Location: to set the folder where 
you wish all Word documents to be saved by default. 
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3. In the Word Options dialog, click on Advanced in the options on the left. Scroll 
down to the General section and click the File Locations button. 

 
Click on User Templates and then click 
on the Modify button.  

Navigate to and set the folder C:\Program 
Files\Microsoft Office\Templates. Click 
OK to save the setting.  

This will set the default template location 
for both Word and Excel so that the 
TDOT template folders will be available. 
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4. In the Word Options dialog, click on Trust Center in the options on the left. 

 Click on the Trust Center Settings button. 
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5. In the Trust Center dialog, click on Trusted Locations in the options on the left. 
Select the trusted location for Application Templates.  
All files stored under Trusted Locations will automatically load macros without any 
action from the user. 

 
The settings for Application Templates are at the bottom. The Path should be set to 
C:\Program Files\Microsoft Office\Templates and Sub Folders should be set to 
Allowed.  

If sub folders are Disallowed, click on the Modify button. In the dialog which opens, 
click on the Subfolders of this location are also trusted option and click OK.  
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6. In the Trust Center dialog, click on the Add new location button. 

Click on the Browse button and navigate to the location where your project files are 
stored.  
Click on the Subfolders of this location are also trusted option, key in a description 
if desired and click OK.  

 

With your project folders defined as trusted locations, all macros will automatically 
be enabled.  
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If you open a Word 2010 file with macros that is not in a trusted location, the 
following two settings will provide you the opportunity to enable the macros as 
needed. 

7. In the Trust Center dialog, click on Macro Settings in the options on the left. The 
option Disable all macros with notification should be set.  

 
8. In the Trust Center dialog, click on Message Bar in the options on the left. The 

option Show the Message Bar in all applications when active content, such as 
ActiveX controls or macros, has been blocked should be set.  
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9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings 
just made. 

10. This completes the settings under Word Options, so click the OK button at the 
bottom of that dialog to complete the Word 2010 set up.  

Excel: 
1. In Excel 2010, click on the File tab at the far left of the ribbon and choose Options 

from the drop down list. 
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2. In the Excel Options dialog click on Save in the options on the left.  

Set the Save Files in this format: option to Excel Workbook (*.xlsx). 
Change the path given for Default File Location: to set the folder where you wish all 
Excel documents to be saved by default. 
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3. In the Excel Options dialog, click on Trust Center in the options on the left. 

 Click on the Trust Center Settings button. 
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4. In the Trust Center dialog, click on Trusted Locations in the options on the left. 
Select the trusted location for Application Templates.  

All files stored under Trusted Locations will automatically load macros without any 
action from the user. 

 
The settings for Application Templates are at the bottom. The Path should be set to 
C:\Program Files\Microsoft Office\Templates and Sub Folders should be set to 
Allowed.  

If sub folders are Disallowed, click on the Modify button. In the dialog which opens, 
click on the Subfolders of this location are also trusted option and click OK.  
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5. In the Trust Center dialog, click on the Add new location button. 

Click on the Browse button and navigate to the location where your project files are 
stored.  
Click on the Subfolders of this location are also trusted option, key in a description 
if desired and click OK.  

 

With your project folders defined as trusted locations, all macros will automatically 
be enabled.  
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If you open an Excel 2010 file with macros that is not in a trusted location, the 
following two settings will provide you the opportunity to enable the macros as 
needed. 

6. In the Trust Center dialog, click on Macro Settings in the options on the left. The 
option Disable all macros with notification should be set.  

 
7. In the Trust Center dialog, click on Message Bar in the options on the left. The 

option Show the Message Bar in all applications when active content, such as 
ActiveX controls or macros, has been blocked should be set.  
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8. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings 
just made. 

9. This completes the settings under Excel Options, so click the OK button at the 
bottom of that dialog to complete the Excel 2010 set up.  

Saving Documents with Macros 

If you try to save a new document that has macros with the default file formats, .docx or 
.xlsx, then you will be warned that all macros will be thrown out since those file types are 
specifically macro free. 

 

If you no longer need the macros, simply click Yes to save the file in the macro free 
format. Otherwise, click No to stop at this point. 

To keep macros for later use, go to File > Save As and under Save As Type choose the 
macro-enabled one. 

 

Previously saved documents automatically save in their current format. 



 16 

Enabling macros that are not in a trusted location 
If you open a file with macros that is not in a trusted location, a Security Warning 
message bar will appear. 

 
If you need to use the macros, click on the Enable Content button in the message bar. 
The Security Warning message bar goes away and macros are ready for use. 

Once a document has been trusted, Office 2010 remembers the name so that it will not be 
necessary to Enable Content again later. If you wish to clear the trusted document list or 
to disable this functionality, go to File > Options > Trust Center > Trust Center 
Settings. Choose the Trusted Documents option on the left and reset as desired. 
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Excel Template Files 
T.D.O.T. Design Division Excel templates used with MicroStation V8 are part of the 
standard Office file downloads from the TDOT CADD web page. The templates are 
listed below with their default folder locations.  

C:\Program Files\Microsoft Office\Templates\Survey 
ROWAcqTable.xltm        ROWAcqMetric.xltx 
Utility Owners.xltx 

C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets 
Bridge Quantities.xltm 
Estimated Roadway Quantities.xltm 

Maintenance Quantities.xltm 
Project Commitments.xltx 

C:\Program Files\Microsoft Office\Templates\TDOT English Tab Quantities 
Box Bridge.xltx 
Box Culvert.xltx 
Bridge Drains.xltx 
Catch Basins and Manholes.xltx 
Catch Basins.xltx 
Concrete Median Barrier.xltx 
Cross Drain Arterials WO Full Access Control.xltx 
Cross Drain Collectors.xltx 
Cross Drain Freeways.xltx 
Cross Drain Local Roads.xltx 
Drop Inlets.xltx 
Enhanced Silt Fence Check Design Dimensions.xltx 
Erosion Prevention and Sediment Control.xltx 
Grading Quantities Composition Known.xltx 
Grading Quantities Composition Unknown.xltx 
Guardrail Tab Builder.xltm 
Guardrail.xltx 
Manholes.xltx 
Median Drains.xltx 
Pavement.xltx 

Removal Of Buildings & Obstructions.xltx 
Removal Of Structures.xltx 
Rip Rap Basins.xltx 
Rip Rap Ditches.xltx 
Roadway Approaches.xltx 
ROW Markers.xltx 
Sediment Control Structure Dimensions.xltx 
Sediment Control Structure Quantities.xltx 
Side Drain.xltx 
Slab Bridge.xltx  
Slab Culvert.xltx  
Slope Rehabilitation.xltx 
Special Ditches.xltx 
Spring Drains.xltx 
Storm Drainage Endwalls.xltx 
Storm Drainage Pipe Tab Builder.xltm 
Storm Drainage Pipes.xltx 
Storm Drainage Structure Tab Builder.xltm 
Traffic Control.xltx 
Trees.xltx 

C:\Program Files\Microsoft Office\Templates\TDOT Metric Tab Quantities 
Box Bridge.xltx 
Box Culvert.xltx 
Bridge Drains.xltx 
Catch Basins and Manholes.xltx 
Catch Basins.xltx 
Concrete Median Barrier.xltx 
Cross Drain Arterials WO Full Access Control.xltx 
Cross Drain Collectors.xltx 
Cross Drain Freeways.xltx 
Cross Drain Local Roads.xltx 
Drop Inlets.xltx 
Enhanced Silt Fence Check Design Dimensions.xltx 
Erosion Prevention and Sediment Control.xltx 
Grading Quantities Composition Known.xltx 
Grading Quantities Composition Unknown.xltx 
Guardrail Tab Builder.xltm 
Guardrail.xltx 
Manholes.xltx 
Median Drains.xltx 

Pavement.xltx 
Removal Of Buildings & Obstructions.xltx 
Removal Of Structures.xltx 
Rip Rap Basins.xltx 
Rip Rap Ditches.xltx 
Roadway Approaches.xltx 
ROW Markers.xltx 
Sediment Control Structure Dimensions.xltx 
Sediment Control Structure Quantities.xltx 
Side Drain.xltx 
Slab Bridge.xltx  
Slab Culvert.xltx  
Slope Rehabilitation.xltx 
Special Ditches.xltx 
Spring Drains.xltx 
Storm Drainage Endwalls.xltx 
Storm Drainage Pipes.xltx 
Traffic Control.xltx 
Trees.xltx 
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Estimated Roadway Quantities Excel File 
The Estimated Roadway Quantities Excel file is required on all jobs per the T.D.O.T. 
Design Division Roadway Design Guidelines. A preliminary construction quantity 
estimate Excel file is to be submitted to the Estimating and Bid Analysis Office when the 
Right-of-Way plans are turned in per Section 3-400.15. A complete construction quantity 
estimate Excel file shall be turned in to the Estimating and Bid Analysis Office when the 
plans are turned in for construction, Section 4-140.00. See Section 4-140.05 for details 
on the Estimated Roadway Quantities Excel file.  

This Excel quantities file is used as an input file for a T.D.O.T. computer database 
program. The worksheets names, column and row locations and some heading 
information should not be changed or the database program will not input the data 
correctly.   

There are at least two worksheets required for the Estimated Roadway Quantity Excel 
file, Project Data and Col #1-Est. Rdwy. Quantities. There may be more worksheets 
for a large job or a job with box bridge quantities. 

The Structures and Maintenance division also have estimated quantities Excel files they 
submit to the Estimating and Bid Analysis Office. The templates for these are included in 
the TDOT 2nd Sheets download.  

The Utilities Office of the Right-of-Way Division also has an estimated quantities 
worksheet they submit to the Estimating and Bid Analysis Office. The Utility Office 
provides their estimated quantities Excel worksheet to their users. The Utility Office will 
send a copy of the utility Excel worksheet to the Design Division so the “Estimated 
Utilities Quantities” Sheet 2B for the plans can be produced as per Section 4-137.00 in 
the T.D.O.T. Design Division Roadway Design Guidelines. 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/DesGuide.htm
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/DesGuide.htm
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Create TDOT Estimated Roadway Quantities in Excel  
It is recommended that the user have all of the tabulated quantity blocks in the same file 
with the estimated roadway quantities. By putting all of the worksheets together in the 
same Excel file, the quantities on the different tab block sheet quantities can be linked to 
the estimated quantities sheet. These same tab blocks and quantity blocks will be linked 
to the MicroStation design files. By setting up the Excel estimate file in this way, each 
quantity can be entered and updated in one location only, and will then be updated in 
each of the locations where the value appears.  

These directions will first demonstrate creating the Estimated Roadway Quantities file 
and later describe adding other tabulated blocks. 

1. In Excel, click on the File tab on the far left of the Excel ribbon and choose New 
2. Under New, choose My Templates. 
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3. Go to the TDOT 2nd Sheets tab and select the Estimated Roadway Quantities.xltm 
template 
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4. Fill in the Project Data sheet. Instruction notes are available on the worksheet. Hold 
the mouse pointer over the small red triangles for directions. 
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5. Go to Col #1-Est. Rdwy. Quantities worksheet. Several macros are available to help 
fill out the estimated quantities block. On this worksheet, buttons are provided to 
access the macros with descriptions to the right. 

 
 

Note:  
The file Items.dat must be in the folder C:\Program Files\Microsoft 
Office\Templates\TDOT 2nd Sheets for the ‘Select Item Numbers...’, ‘Fill in 
Description…’ and ‘Import CSV File for Items’ macros to work. The macros will direct 
the user to the website to download the items.dat file if the file is not on the computer in 
the correct location or if it is more than 30 days old. 
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Estimated Roadway Quantities Macros 

Select Item Numbers From List  
Uses the Items.dat file located at C:\Program Files\Microsoft 
Office\Templates\TDOT 2nd Sheets to find items, list them in a selection window and 
write the items selected to the worksheet.  

Search – If the Search for Items field is left blank, the search button will open all of 
the items for either English or Metric items. Put in one or more numbers or letters to 
pull up all items containing those characters. Do not use any wild card characters. 
Use the Shift or Ctrl key to select or unselect multiple items.  

Import – Will prompt for the Excel cell to start placing the selected item numbers.  

Reset – Clears the Items Found list box. 

Close – Closes the Item Select dialog box. 

Search ….          Select desired items … 

         

Import … 
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Fill In Description and Unit  
Uses the Items.dat file located at C:\Program Files\Microsoft 
Office\Templates\TDOT 2nd Sheets to fill in the current description and units for the 
item numbers selected. If the description and unit are left blank, then the item number is 
not in the items.dat file. Check for the item number on the web since it is updated daily 
and save a fresh copy of items.dat as needed to include new item numbers. If the item 
number should be valid but is not found, contact the TDOT manager for the project.  

Select item numbers for fill in …  

 
After fill in … 
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Download Items.dat from Web Page  
This is a direct link to the item numbers web page. Follow the directions shown on the 
right of the web page to save the items.dat file to the folder location C:\Program 
Files\Microsoft Office\Templates\TDOT 2nd Sheets for use with the other macros.  

 

The item number information can be reviewed, cut from the web page and pasted into the 
Excel estimate file using the Search Item Lists option on the left side of the web page. A 
direct Paste or Paste Special as HTML will paste the text into separate cells on the Excel 
estimated items worksheet but formatting will be lost. It will be necessary to run the 
Format Item Numbers macro and perhaps the Format Notes Area macro to replace the 
borders and text formatting. 



 26 

Import CSV File for Items  
Geopak produces quantity calculation files in CSV (comma separated values) format that 
can be input directly into the Excel estimated roadway quantities file. The default CSV 
file format from Geopak is item number, Geopak description, units and quantity.  

This macro imports only the item number and the quantity and then uses the Fill In 
Description … macro to enter the description and unit. The Geopak descriptions do not 
always match the official item descriptions which must be used. 

You are first prompted for the CSV file to import.  

 
Then you are prompted for the starting location in the estimated roadway quantities block 
to start placing data. 

 
Data is then added in Excel.  

 
To import a CSV file as written for other tabulated quantity worksheets, see macro 
description for Import CSV. 
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Sort Item Numbers  
The item numbers need to be sorted in numerical order by the item number. This macro 
sorts the item numbers selected by the user and maintains the correct formatting. The 
macro prompts the user to select the items to be sorted. 
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After sorting, the blank lines at the bottom can be deleted and blank lines between groups 
can be inserted as desired. Select the row by the row number, and right click for row 
Delete and Insert tools. 

 



 29 

Format Notes Area  
Notes can be added after the item numbers but the notes area needs to be formatted 
differently from the item numbers. All of the text for each note should be placed into one 
cell. The macro prompts the user to select the last line of the item numbers area. The 
borders are removed from the notes area, the notes cells are merged and the row height is 
adjusted for multiline notes. 

 
After re-formatting … 
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Format Item Numbers  
The borders, text sizes, fonts, etc. may be changed as the estimate table is being filled in. 
This macro reformats the estimated quantities block to the original size. If there are notes, 
use the Format Notes Area macro to reset that area as needed. 

The Column format macros listed below will Hide and Unhide the extra quantity 
columns. The macros should always be used so that the macro buttons and description 
text will be moved with the columns. 

1 Column format  
For most projects, where there is only one project number, the one column format is used.  

2 Column Format  
For projects that go across two counties or for another reason have two project numbers 
with a total quantities column, there is the two column format.  

3 Column Format  
For projects that go across three counties or for another reason have three project 
numbers with a total quantities column, there is the three column format. 
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Import CSV  
This macro brings in a CSV (comma separated values) file to the worksheet selected, 
starting at the cell selected. This is intended as a way to build tabulation blocks on other 
worksheets, but can be used to bring the CSV file in without having any processing done 
on the information to the estimated roadway quantities block.  

You are first prompted for the CSV file to import …  

 
Then for the worksheet & cell location …  

 
After import …  
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Auto-Build Tabulated Quantity Block Macro Access 
These macros are provided as a way to access the macros in the Excel auto-build 
tabulated quantity block templates. When those templates are inserted as worksheet 
templates, their macros are not brought in. The macro buttons can be re-assigned to these 
macros to access the programs from the original template files.   

BuildCatchBasinsBlock      runcheckitemsCB 
BuildGRBlock        runcheckitemsGR 
BuildStormDrainagePipes     runcheckitemsSS 

See the section Auto-Build Tabulated Quantity Blocks for full descriptions of these 
macros.   
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Alternate Pay Items  
All alternate items must be placed after all of the other roadway items.  

In column C (the description column) on the line preceding the alternate items, enter the 
designation for the alternate as ALTERNATE AA1, ALTERNATE AA2, 
ALTERNATE AA3, etc. AA1 will alternate with AA2 and AA3.  

If there were another set of items to be alternated, they would be labeled ALTERNATE 
AB1, ALTERNATE AB2, ALTERNATE AB3, etc. AB1 will alternate with AB2 and 
AB3. A third set of alternates would be AC1, AC2, AC3, etc. 
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Additional Estimated Roadway Quantities Worksheets Needed 
To add an additional Col #*-Est. Rdwy. Quantities worksheet 

1. Select the worksheet tab, right click and select Move or Copy… 
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2. Identify the workbook and worksheet that should come after the new worksheet. 
Select the Create a copy option and click OK.  

 

 

3. Select the new worksheet’s tab, right click and select Rename. You must keep the 
first three letters as Col so the database program will read the worksheet as estimated 
items. Change the column number and the remaining portion of the name as desired.  

 

Note: 
The Project Data worksheet must be the first worksheet in the file, the estimated roadway 
quantities worksheets (the worksheet names that start with Col) need to be next and then the 
Box Bridge Quantities worksheet (if there is a box culvert or bridge on the project). Any 
unused worksheets can be deleted. 
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Add other Tabulated Quantities Blocks 
Note: Cells with a red border on tabulated quantity sheets indicate that the cell contains a formula 
to sum the contents of the column or row. 

To add other tabulated quantities blocks: 

1. Highlight a worksheet tab, right click the mouse and select Insert.  

2. Select the template group wanted, for example TDOT English Tab Quantities.  

 
3. Select the template wanted and click OK. The template is used to create the new worksheet. 
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 The template will come in ahead of the worksheet selected. To change the order of the 
worksheets, select the worksheet tab, hold the left mouse button down and then drag and drop to 
the location wanted; or select the worksheet tab of the worksheet to be moved, right click and go 
to Move or Copy…  

The Project Data worksheet must be the first worksheet in the file, the estimated roadway 
quantities worksheets (the worksheet names that start with Col) need to be next and then the Box 
Bridge Quantities worksheet (if there is a box culvert or bridge on the project) before the 
tabulated quantities worksheets.  

Standard Tabulated Quantity Template Formatting 

1. All fonts are Arial. 

2. Body text is size 10, not bold. 

3. The main heading text is size 15, bold. 

4. The sub heading text is size 10, bold. 

5. The body horizontal lines are light weight. 

6. The heading borders and vertical lines are medium weight. 

7. Select body cells and set justification as wanted. 

8. Use Center Across Selection under Format Cells > Alignment > Horizontal to center 
heading text across multiple columns.  

9. Cells for non-quantity data, footnote numbers or footnotes should be formatted as Text under 
Format Cells > Number. 

10. Cells for quantity data should be formatted as either General if no control of decimals is 
needed or as Number to control the number of decimal places under Format Cells > Number. 

11. Multi-line footnote formatting: 
Entire note should go in column C cell 
Select all cells from column C to end of tabulation block 
Under Format Cells > Alignment  
 Set justification to Horizontal: Left & Vertical: Top  
 Turn on Wrap Text & Merge Cells 
Adjust row height so that all lines of footnote are visible 
Set Vertical justification to Top for footnote number cell in column B  
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Auto-Build Tabulated Quantity Blocks 
The following Excel templates include macros that automatically build the tabulation 
blocks using data files generated by Geopak. 

Guardrail Tab Builder.xltm  
Storm Drainage Pipe Tab Builder.xltm 
Storm Drainage Structure Tab Builder.xltm  

Guardrail Tab Builder 
The macro in template Guardrail Tab Builder.xltm builds the guardrail block from a 
guardrail output file created with Geopak’s Design & Computation Manager Pay Items. 
The macro also runs the Check Items Numbers program to verify all item numbers 
which are used. 

 See the GEOPAK Road Course Guide, D&C Manager – Additional Functions, 
Section 20c. Quantities for directions to create the guardrail output file using the Comp 
Book format. An example is shown below. 

 
Do not use the Append function in Geopak to add guardrail quantities from multiple 
roadways together in the same file. Instead, generate each roadway guardrail tabulation in 
separate files and then combine using any text editor. The Append function uses line 
feeds that are not recognized by Excel and will cause this program to fail. 
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In Excel, click the Build Guardrail Block button and the user is given a file open dialog 
to Select Geopak Guardrail Pay Items Output File. Once the file is identified, the 
macro reads the data and builds the block. 

 
Different roadways are sorted alphabetically based on the roadway chain name from the 
output file. 

If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file 
then it will be necessary to re-assign the macros for the buttons. Select a location away 
from the macro button, right click over the button and choose the Assign Macro option. 
From the macro list, pick BuildGRBlock for the top button & click OK to finish. Assign 
runcheckitemsGR to the bottom button. If you do not see these macros listed in your 
estimated roadway quantities file, then you will have to either set it up in a file by itself 
or update your estimated roadway quantities Excel file to the latest version of that file 
which includes these macros. 
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Storm Drainage Pipe Tab Builder 
The macro in template Storm Drainage Pipe Tab Builder.xltm builds the storm 
drainage pipe tabulation block from the drainage report file created with Geopak 
Drainage using the drainage report format file TDOTlinksFULL.drf. The macro also 
runs the Check Items Numbers program to verify all item numbers which are used. 

In Excel, click the Build Storm Drainage Pipe Block button and the user is given a file 
open dialog to Select Storm Drainage Link Report File. Once the file is identified, the 
macro reads the data and builds the block. 

 
If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file 
then it will be necessary to re-assign the macros for the buttons. Select a location away 
from the macro button, right click over the button and choose the Assign Macro option. 
From the macro list, pick BuildStormDrainagePipes for the top button & click OK to 
finish. Assign runcheckitemsSS to the bottom button. If you do not see these macros 
listed in your estimated roadway quantities file, then you will have to either set it up in a 
file by itself or update your estimated roadway quantities Excel file to the latest version 
of that file which includes these macros. 
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Storm Drainage Structures Tab Builder 
The macro in template Storm Drainage Structure Tab Builder.xltm builds the storm 
drainage catch basins, junction boxes and manholes tabulation block from the drainage 
report file created with Geopak Drainage using the drainage report format file 
TDOTnodesFULL.drf. The macro also runs the Check Items Numbers program to 
verify all item numbers which are used. 

In Excel, click the Build Catch Basins and Manholes Block button and the user is given 
a file open dialog to Select Storm Drainage Node Report File. Once the file is 
identified, the macro reads the data and builds the block. 

 
If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file 
then it will be necessary to re-assign the macros for the buttons. Select a location away 
from the macro button, right click over the button and choose the Assign Macro option. 
From the macro list, pick BuildCatchBasinsBlock for the top button & click OK to 
finish. Assign runcheckitemsCB to the bottom button. If you do not see these macros 
listed in your estimated roadway quantities file, then you will have to either set it up in a 
file by itself or update your estimated roadway quantities Excel file to the latest version 
of that file which includes these macros. 
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Link Tabulated Quantity Block to Estimated Roadway Quantities Worksheet 
To link cells from tabulated quantity block worksheets to the estimated roadway 
quantities worksheet: 

1. Select the cell where the linked value will be displayed. Enter the equal sign, = 

2. Click to the worksheet and cell to be linked.  

3. When the correct worksheet name and cell address are entered into the formula bar 
entry window, click on the check mark,  on the formula bar.  

Note: The cell must be formatted as “number” or “general” or the link will display as 
text.  

Do not have quantities linked to values in separate workbooks. The Estimating and Bid 
Analysis Office will not accept files with links to separate Excel files. A Copy and Paste 
Special> Values to the same location will replace the link with the current value. 
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Excel Linking to MicroStation 

In Excel 
1. Prepare the Excel file as needed. Save the Excel file to your project folder. The link 

will not be correct if the Excel file is not saved onto your computer or computer 
network before attaching to MicroStation V8.  

2. Select the information in Excel wanted for linking to MicroStation. Select an extra 
row and column on each side of the block so that the width of the border lines on the 
edges of the tabulated block are not cut in half. 

3. Go to the ribbon menu at Home > Clipboard and choose Copy or right click on your 
mouse and pick Copy from the choices given. This puts the selected information into 
the Windows Clipboard. 
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In MicroStation V8 
Have a 2d design file ready with a sheet border placed in it or open the plans sheet 
MicroStation DGN file. As with most design files for T.D.O.T. projects, the design file 
should be created from the T.D.O.T. Design Division Seed2d.dgn seed file, which is part 
of the T.D.O.T. Design Division standard CADD files downloads.    

Name the MicroStation DGN sheet file according to CADDV8.pdf , Section Standard 
Filenames, part Standard Sheet File Types: (Use .SHT extension). For example, use 
the name 002A.sht for the first ESTIMATED ROADWAY QUANTITIES 
MicroStation sheet file.  

There are several reasons why the MicroStation DGN sheet files need to be named 
according to the Standard Sheet File naming recommendations. One, the project will be 
very easy to plot using InterPlot Organizer where the sheets will automatically be in 
order. Two, the names of the sheet files must be the same as the sheet number so that 
when the sheet is published on FileNet, other divisions, such as Right-of-Way and 
Construction, can easily find and use the files produced by the Design Division. 

It works best to use a one-scale sheet border for the 2nd sheet files. Other links can be 
placed on a plans sheet at the scale of the sheet, such as an erosion control quantities 
block or a right-of-way acquisition table. 

The Excel link will be placed on the active level in MicroStation V8.  

1. On the MicroStation menu bar, go to Edit > Paste Special…  
Select the Linked Microsoft Excel Worksheet option and click the Paste button, 

 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/caddv8.pdf
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2. In the Tool Settings dialog, Set Paste as: Link and Method: By Size.  Under the extra 
options, click on Rotate With View (MicroStation V8i). 

 
3. Set the Scale as needed from the table below. The scale values for .14 text size are 

recommended for the best legibility in the plans. 

English: 
For Arial font, text size 10 in Excel (font and size in TDOT templates): 
1-scale size sheet, set the scale to: 
17  for .14 text size  -  this will measure 0.14 feet in MicroStation and 

will measure 0.14 inch on the printed sheet 
15  for .12 text size 
13  for .10 text size 

50-scale size sheet, multiply the scale above by 50: 
850  for .14 text size 
750  for .12 text size 
650  for .10 text size 

For sheets at other scales, multiply the 1-scale above by the scale of the sheet: 
17  x  Scale  for .14 text size 
15  x  Scale  for .12 text size 
13  x  Scale  for .10 text size 

Metric: 
For Arial font, text size 10 in Excel (font and size in TDOT templates): 
1-scale size sheet, set the scale to: 
1.4  for .14 text size  -  this will measure 0.0035 meters in MicroStation and 

will measure 0.14 inch on the printed sheet 
1.2  for .12 text size (0.0030) 
1.0  for .10 text size (0.0025) 

For sheets at other scales, multiply the 1-scale above by the scale of the sheet: 
1.4  x  Scale  for .14 text size 
1.2  x  Scale  for .12 text size 
1.0  x  Scale  for .10 text size 
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4. You are prompted to Select Object Position. Data point to place the link.   

 
After placement, the OLE attachment can be manipulated as a graphic element. It can be 
moved, copied and scaled as needed. 

If the Office document is open at the time you are looking at the link in MicroStation, it 
will appear shaded.  
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Because the Excel file link is attached as a picture, the text cannot be measured directly. 
Zoom in and use the measure tool to see if the body (not the headings) text is 
approximately the correct size. 
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Open & Update the Excel OLE Attachment 
The changes made to the Excel files outside of MicroStation will not be changed in 
MicroStation until the Excel links have been opened & updated.  

Use one of the following methods:  

1. In MicroStation, start the Element Selection tool and double click on the link to be 
revised. The Excel file is opened. Make any changes that may be needed and save the 
file. The link is updated in MicroStation.  

2. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be 
revised and click Open Source. The Excel file is opened. Make any changes that may 
be needed and save the file. The link is updated in MicroStation.  

You should not use the Update Now option in the Links dialog without opening 
the document first. The link may be updated but errors are generated and you may 
corrupt your MicroStation file. 

3. In MicroStation, select the link to be revised and the Worksheet Object tools are 
enabled. Go to Edit > Macro-Enabled Worksheet Object > Edit. The Excel file is 
opened Make any changes that may be needed and save the file. The link is updated 
in MicroStation. 

4. Open all linked files in Excel. In MicroStation, go to Edit > Update Links.  

This function should update all of the links in the file without opening the links. 
When used with Office 2010, errors are generated and nothing may be updated. 

Relinking 
When the sizes of the rows or columns are changed, the area linked will still be displayed 
in MicroStation but will be warped or truncated. It will need to be relinked to correct the 
display in graphics. 

To relink an Excel file: 

1. Move the existing link graphics away from the sheet border. 

2. Open the Excel file. 

3. Follow the directions for a new link. See section Excel Linking to MicroStation. 
4. After the new link has been established and is correct, the link graphics from the 

old link can be deleted. 
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Word Embedded in MicroStation 
Word Documents Embedded in MicroStation DGN Seed Files 

There are MicroStation design file seed files set up for the 2nd sheets with the T.D.O.T. 
Word documents embedded. These seed files have sheet borders set up at a one-scale. 
MicroStation seed files with embedded Word documents: 

EnglishDropOffNotes.dgn 
EnglishEPSCSpecialNotes.dgn 
EnglishGeneralNotes.dgn 
Ind&StdDwgsEng.dgn 

Ind&StdDwgsMet.dgn 
MetricDropoffNotes.dgn 
MetricEPSCSpecialNotes.dgn 
MetricGeneralNotes.dgn 

In MicroStation 
1. From MicroStation or MicroStation manager,  

Go to File > New in MicroStation or click the New File icon in MicroStation 
Manager …, and in the project folder, Browse to select the seed file needed for the 
sheet, assign the name according to the sheet name directions and assign a *.sht 
extension. See CADDV8.pdf, Section Standard Filenames, part Standard Sheet 
File Types: (Use .SHT extension). For example, use the name 001A.sht for the 
ROADWAY INDEX AND STANDARD DRAWINGS INDEX MicroStation sheet 
file. 

There are several reasons why the MicroStation DGN sheet files need to be named 
according to the Standard Sheet File naming recommendations. One, the project will 
be very easy to plot using InterPlot Organizer where the sheets will automatically be 
in order. Two, the names of the sheet files must be the same as the sheet number so 
that when the sheet is published on FileNet, other divisions, such as Right-of-Way 
and Construction, can easily find and use the files produced by the Design Division. 

 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/caddv8.pdf
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The OLE link is displayed as a ‘picture’ of the Word document. It has a shape around 
the edge. The OLE link can be copied, moved or scaled using the graphics 
commands.  

2. In MicroStation, use the Element Selection tool and double click on the embedded 
Word document. The embedded document will open in Word. 
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3. Note that the Word document header says Document in DesignFileName.sht. Make 
edits as needed 

Editing Notes: 
Occasionally information previously deleted needs to be added back into the Word 
document. This can be accomplished by cutting and pasting from other open Word 
documents. To open a temporary General Notes or Index and Standard Drawings file 
in Word, go to the File tab at the far left of the ribbon and choose New > My 
Templates >TDOT 2nd Sheets > English General Notes.dotx or English Index & 
Std Dwgs.dotx. Cut from the temporary document and paste to the document in the 
sheet file. Close the temporary document without saving. 

In General Notes documents, each section is numbered starting at 1 (one). If the 1st 
note in a section is deleted, the remaining notes will pick up the numbering sequence 
from the previous section. To correct this, highlight the first note in the section, right 
click and choose the option Restart at 1.  

 
4. After making the edits wanted, go to the File tab at the upper left and choose Save or 

click on the Save icon at the upper left. Changes made in the Word document will not 
be shown in MicroStation until the Word document is closed. 
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5. The only access to an embedded document is from the graphics in the MicroStation 
design file. If the graphic display of the embedded Word document is deleted, the 
Word document will be deleted. If MicroStation has not been closed and the file has 
not been compressed then the graphics and the Word document can be recovered 
through the Undo command.  

For this reason, it is recommended that a copy of the Word file information be 
made after significant edits have been done.  
This can be done several ways. In the Word document, go to the File tab at the upper 
left and select Save As to make a copy to the project folder. In MicroStation, the OLE 
link graphics can be copied to the side creating separate OLE link of the edits at that 
moment which creates an additional separate embedded Word document. Of course, a 
backup copy of the entire MicroStation DGN file can be made as well. 
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More than one Sheet Needed 
If more than one plan sheet will be needed for General Notes or Index sheets: 

1. Make edits as needed to the Word document embedded in the first sheet and close the 
Word document. 

Since the text is not easily moved from one MicroStation design file to another, it is 
recommended that all of the edits be made to the first MicroStation General Notes or 
Index design file before creating the additional sheets. 

2. In MicroStation, go to File> Save As and save as the next sheet needed. There should 
be a separate design file for each sheet in the set of plans except for cross-section 
sheet files. For example, do a ‘Save As’ on the General Notes design file 002G.sht to 
002H.sht. 
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3. In the new MicroStation sheet file, edit the Word document. Highlight all of the text 
(except the heading if needed) on the first page in the Word document and delete it. 
Save & close the Word document to see the changes in the MicroStation file.  

 
4. Repeat as needed for additional sheets.  
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Embedding Word Documents in Existing MicroStation DGN Sheet Files 
Sometimes you need to add small groups of notes to existing plan sheets in MicroStation 
V8. This section describes the process of embedding the Word documents in 
MicroStation. A good example of this is ROW notes. 
The TDOT Word documents embedded in the MicroStation seed files are also available 
as Word templates. These can be used to add notes or standard drawings back into full 
sheets as needed.  

T.D.O.T. Design Division Word templates used with MicroStation V8 at  

C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets: 
Bridge Index.dotx  
English Drop Off Notes.dotx 
English EPSC Special Notes.dotx 
English General Notes.dotx 
English Index & Std Dwgs.dotx 
IB_To Be Printed with Plans_English.dotx 

IB_To Be Printed with Plans_Metric.dotx 
Metric Drop Off Notes.dotx 
Metric EPSC Special Notes.dotx 
Metric General Notes.dotx 
Metric Index & Std Dwgs.dotx 
ROW Notes.dotx   

1. In Word, go to the File tab at the upper left, choose New > My Templates > TDOT 
2nd Sheets, and select the type note file needed. (Or use your own notes.) 

2. Edit the notes as needed. Select and copy to put the text into the Windows Clipboard. 

3. In MicroStation, go to Edit > Paste Special…, select the Embedded Microsoft 
Office Word Document option and click the Paste button. 

 
The OLE attachment will be placed on the active level, reset as desired before 
embedding. 
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4. Select Paste as: Embedded and Method: By Corners. Under the extra options, click 
on Rotate With View (MicroStation V8i). 

 
5. Data point at the location where the upper left corner of the notes need to start. This 

sets the first corner and you are prompted to Select Rectangle Corner. 
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In the MicroStation keyin field we now need to enter a dx= precision keyin to set the 
corner across from our first point. The dimension used in this keyin is determined by 
the scale of the plan sheet as well as the width dimension of the document inside of 
Word. Full sheets in Word are set up as 11” X 17” but small groups of notes are 8 ½” 
X 11”. All dimensions listed below are for 8 ½” X 11” documents; for 11” X 17” 
documents attached in this manner take the dimension values and multiply by 2 

English: 
For Arial font, text size 7 in Word (font and size in TDOT templates): 
1-scale size sheet, use dimension keyin: 
dx=13 for .14 text size  -  this will measure 0.14 feet in MicroStation and 

will measure 0.14 inch on the printed sheet 
dx=11  for .12 text size 
dx=9  for .10 text size 

100-scale size sheet, multiply the dimension above by 100: 
dx=1300  for .14 text size 
dx=1100  for .12 text size 
dx=900 for .10 text size 

For other scales, multiply the 1-scale dimension above by the scale of the sheet: 
13  x  Scale  for .14 text size 
11  x  Scale  for .12 text size 
9  x  Scale  for .10 text size 

Metric: 
For Arial font, text size 7 in Word (font and size in TDOT templates): 
1-scale size sheet, set the dimension keyin to: 
dx=0.33  for .14 text size  -  this will measure 0.0035 meters in MicroStation and 

will measure 0.14 inch on the printed sheet 
dx=0.28  for .12 text size (0.0030) 
dx=0.23  for .10 text size (0.0025) 

For other scales, multiply the 1-scale dimension above by the scale of the sheet: 
0.33  x  Scale  for .14 text size 
0.28  x  Scale  for .12 text size 
0.23  x  Scale  for .10 text size 
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6. To determine the required dimension, take the dimension used for a 1 scale sheet and 
multiply it by the scale of the plan sheet. In our example, we are adding some ROW 
notes to a 100 scale property map sheet (13 X 100 = 1300). 

 Enter dx=1300. The document now appears on the sheet. The dx=1300 keyin yields 
0.14 tall body text when plotted at a scale of 100. 

 
7. Use MicroStation’s Move Element command to position the link as needed. The 

temporary Word document used to copy the notes from can be closed without saving 
since the document is now embedded in the MicroStation DGN file. 

Additional Notes concerning this method of Embedding 
The By Corners method is used for Word documents to ensure that the text comes in at 
the correct size. The By Scale method does not yield consistent results when used with 
Word attachments. That method is used with Excel attachments. 

The dimension keyin given only specifies the dimension across the sheet. Depending on 
the contents of the Word document the height will vary while the width remains constant 
based on the width of the document in Word. 

Because the embedded Word file is attached as a picture, the text cannot be measured 
directly. Zoom in and use the measure tool to see if the body (not the headings) text is 
approximately the correct size. 
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Open & Update the Word OLE Attachment 
Embedded Word Documents 
In MicroStation, start the Element Selection tool and double click on the document to be 
revised. The Word file is opened. Make any changes that may be needed and save the 
file. The document is updated in MicroStation.  
Linked Word Documents  
Linking Word 2010 documents instead of embedding them is not recommended due to 
several compatibility issues between Word 2010 and older versions of MicroStation V8. 
Any made with Office 2010 will have to consider the following if it is necessary to open 
& update them in MicroStation V8 versions prior to MicroStation V8i including 
MicroStation V8 2004. 

Word 2010 documents linked to MicroStation cannot be opened from inside 
MicroStation and they cannot be updated until they are open in Word.  
In order to update these after being linked, you must first open the document through 
Word 2010. After making any needed edits, save the file and then with it open in Word, 
use one of the following methods to update what appears in MicroStation. 

1. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be 
updated and click Update Now.   

2. In MicroStation, go to Edit > Update Links.  

To use this method, it will be necessary to open all linked files first.  
It should update all of the links in the file without opening the links but when used 
with Office 2010 without the files open, errors are generated and nothing is updated.  
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Correcting Overlapping Text from Embedded Word Documents 
With previous versions of Office and MicroStation when the height of the text area in the 
embedded Word document was reduced from what it was when originally set up then the 
text became warped causing text characters to overlap. This could occur when more than 
one plan sheet is needed and the last sheet does not have full text columns or perhaps in a 
case where you have less than one full sheet and the columns are adjusted to be the same 
height. It could also happen if after you have added a small set of notes, one or two are 
removed.  

This problem appears to be corrected with Office 2010 and MicroStation V8i.  If 
you are using MicroStation V8 2004 then you may still run into it.  
Take the following steps to re-embed the document and correct this problem:  

1. After edits are done to the embedded Word document, the text becomes warped and 
overlaps in MicroStation. 

 
2. Open the document and in Word go to the Office button at the upper left and select 

Save Copy As… to save the document outside the MicroStation DGN file to your 
project folder. 

3. Open the Word document from your project folder, select and copy to put the text 
into the Windows Clipboard. 

4. In MicroStation, delete the original embedded document or move it to the side off the 
sheet. 

5. The OLE attachment will be placed on the active level, reset as desired. 
6. In MicroStation, go to Edit > Paste Special…, select the Embedded Microsoft 

Office Word Document option and click the Paste button. 
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8. Select Paste as: Embedded and Method: By Corners. Under the extra options, click 
on Rotate With View (MicroStation V8i) 

7. Data point at the location where the upper left corner of the data needs to start on the 
sheet. This sets the first corner and you are prompted to Select Rectangle Corner. 

8. In the MicroStation keyin field enter the required dx= keyin to set the corner across 
from the first point.  

The dimension used in this keyin is determined by the scale of the plan sheet as well 
as the width dimension of the document inside of Word. General Notes and Index 
sheets are set up as full sheets in Word at 11” X 17” and in MicroStation at a scale of 
1 so you should use dx=26 for them. Refer to the table of values in the previous 
section for use when embedding Word documents in MicroStation. 

After re-embedding … 
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Formatting Word Documents 
The Office 2010 interface includes a series of tab options across the top, each of which 
displays a “ribbon” of command options. As you expand or shrink the width of the Office 
window, these commands are adjusted to show less or more. You can right click over the 
top of the ribbon to minimize it when not in use if desired. 

 
When you right click from text in your document, some quick formatting tools are shown 
above the regular right click option list. 
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Show/Hide Formatting 
The Word documents created for TDOT plans production contain special formatting so 
they will appear correctly on the plan sheets. Text styles, tabs, bullets and numbering, 
paragraph indents, hanging indents, columns, column breaks, page breaks and more are 
used. These are non-printing characters and do not show in the normal view in Word. In 
order to edit the Word documents successfully, it is often helpful to see these formatting 
characters.  

To display the formatting characters, use the Show/Hide display command. It is located 
on the Office 2010 ribbon under the Home tab in the Paragraph section. It appears as a 
paragraph mark.  

Click on the Home tab. Look at the Paragraph section of the ribbon and click on the 
Paragraph mark to Show/Hide formatting characters. 

 
 
Clicking the paragraph mark will toggle off and on the display of the formatting 
characters. When it is toggled on, we can see section breaks, paragraph marks, tabs, etc. 
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Text Styles in Word 
A text style will set all of the characteristics for the specified text. This includes font, font 
size, tabs, indents, color, heading, bullets and numbering, etc. There are text styles for 
each type of text used in the TDOT 2nd sheet Office templates. These text styles all start 
with V8. 

Text style controls can be found on the Word 2010 ribbon under the Home tab in the 
Styles section.  

Word 2010 includes a type of style control called Quick Styles. When you move your 
cursor mark over the quick style it temporarily applies that style to the entire paragraph 
where your typing insertion point is currently located. In the example below, I was in the 
first note and it dynamically shows what it would look like with the style Heading 1 
applied to it. To apply the style permanently, left click on your mouse. 
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Click the arrow with the line above it at the bottom of the Quick Styles scroll bar to see 
all of the quick styles currently available.  

 

There are 2 ways to access the standard TDOT 2nd sheet text styles. You can click on the 
Apply Styles option which appears at the bottom of the Quick Styles drop down menu 
shown above. This opens up the Apply Styles dialog. You could also click the small 
square with the arrow in it at the lower right of the Styles section title bar. This opens up 
the Styles list. 
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Indents, Hanging Indents, Line Spacing, Tabs, etc. 
To see the indents, hanging indents, tabs, etc. put the cursor at the text/paragraph in 
question, right click and select Paragraph. Note that the Tabs can be accessed at the 
lower left of the dialog. To change any of these settings, select the text to be changed, go 
to the Paragraph dialog and make the changes as needed. 

You can also access the Paragraph dialog on the Office 2010 ribbon under the Home tab 
in the Paragraph section. Click the small square with the arrow in it at the lower right of 
the Paragraph section title bar. 

    
Indent & Spacing controls can also be found on the Office 2010 ribbon under the Page 
Layout tab in its Paragraph section. 
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 Numbering & Bullets 
You can access Numbering and Bullets on the Office 2010 ribbon under the Home tab 
in the Paragraph section. Click either of these to use the current active format or click 
the arrow next to them to pull out the drop down menu for them. From the drop down 
menus choose Define New Number Format or Define New Bullet to set up a new 
format. 

       
Position yourself in a given numbered paragraph and right click for various numbering 
controls. 
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Page Setup 
You can access Page Setup on the Office 2010 ribbon under the Page Layout tab. The 
Page Setup section includes controls for the margins, orientation, size and columns of 
the page. 

 
The TDOT General Notes and Index & Standard Drawings templates have a paper size of 
11” x 17” and use a landscape orientation 
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Columns 
You can also access Column formatting controls in the Page Setup section on the Office 
2010 ribbon under the Page Layout tab.  

The TDOT General Notes and Index & Standard Drawings templates are set up into three 
columns. The number of columns and justification can be set from the Column drop 
down menu. 

 
To set widths and other column settings, select the More Columns option from the drop 
down menu to open the Columns dialog. 
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Breaks 
You can also access the Break controls in the Page Setup section on the Office 2010 
ribbon under the Page Layout tab.  

Turn the Show / Hide formatting display on to see page, column and section breaks. Use 
the Delete key to remove a break. Use the drop down menu from Breaks in the Page 
Setup section to insert a page, column or section break as needed. 

 
You can also insert a Page Break from the Pages section on the Office 2010 ribbon 
under the Insert tab.  
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Current Office\MicroStation Issues 
This section describes current known issues with Office documents that are linked or 
embedded in MicroStation. 

“Word cannot start the converter mswrd632.wpc” Error Message 
This error is caused because of the operating system security update for Windows XP, 
Windows 2000, and Windows Server 2003 published on December 8, 2009.   

Microsoft Office uses its own text converters to open Word attachments to MicroStation 
so this does not truly present a problem. The error message appears anytime you either 
open a Word document embedded in MicroStation or when you are embedding a Word 
document in MicroStation. 

When the error message is encountered, simply click the OK button or the red X in the 
upper right corner. The message will pop up 1 or 2 times more, continue to click until it 
stops. When the message stops displaying you may need to click on the MicroStation title 
bar to make it active once more. At that point your document will open in Word or if 
attaching to MicroStation, the Paste OLE option settings come up so you can complete 
the attachment. 

 
Note:  
This issue can be resolved through unregistering the mswrd632 converter by editing the 
operating system registry. The change will effectively unregister the converter and 
disable it for third-party applications and for Microsoft Office.  

Consultants who wish to apply this solution should go to Microsoft online for the 
appropriate steps to take for their systems. As of May 2010, there are no current plans to 
try to apply the fix on Design Division computers due to the time it would take and since 
it does not present a serious issue.  
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Word Document Text Not Visible In MicroStation 
After editing a Word document embedded in MicroStation and closing the document, the 
text no longer appears in MicroStation; instead, the attachment appears completely white. 

Although this has only been encountered a few times, it does warrant mention. The cause 
of this problem is not currently known but it can be easily fixed.  

Open the document in Word; it should appear normally in there. Then use one of the 
following methods to rebuild the attachment... 

Select all of the text and copy it to the clipboard. In MicroStation, create a new DGN 
file from the standard seed file for those sheets. Open its embedded Word document, 
select all text and paste from the clipboard and save. 
 
or … 

Use Save As and save the Word document outside of MicroStation. Create a blank 
MicroStation DGN file and using regular embedding methods described previously in 
this document, embed the saved Word document in MicroStation.  
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