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General Information 

The methods and standard files presented in this document represent the needs & 
recommendations for projects developed by T.D.O.T. Design Division personnel and consultants 
doing projects for the Design Division. Other divisions within T.D.O.T. may require that other 
actions be taken in regards to converting project data. It is recommended that consultants contact 
their T.D.O.T. Managers from those other divisions as needed to determine the proper course of 
action concerning their specific project files. 

Throughout this document V7 refers to MicroStation or GEOPAK software version 7 which 
TDOT has used for the past few years. V8 refers to MicroStation or GEOPAK software version 
8 which is now being implemented. 

The methods used to link Office documents to MicroStation for the creation of 2nd sheets have 
not changed very much but the way that MicroStation does this has changed. Due to the changes 
in the way MicroStation displays these documents it will be necessary to change the format, 
fonts, spacing, etc. in existing project documents. Special conversion macros have been 
developed to convert Word & Excel project documents to their new formats. This document 
includes descriptions of those macros and other pertinent information concerning the conversion 
to use MicroStation V8 with Office 2003 or 2007. 
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MicroStation 

The most notable change in MicroStation V8 is the expanded level structure. Several old V7 
levels have been expanded to multiple levels. This will allow more precise control on what is 
shown on our plans sheets as well as providing more flexibility when developing those plans. 
However when converting V7 project data to V8 it is not necessary to take the time to move all 
graphics to their new level locations. In some cases you may wish to move some graphics in 
order to take advantage of these new levels and of course all standard functions will 
automatically use them but you do not have to move old graphics. Most old V7 levels still 
contain the same type of data they did previously and as such are still included on the sheets 
where they were used in V7. One exception to this are the levels for profile graphics which are 
now on all new levels. A special level filter is provided that includes both V8 and V7 levels for 
profile graphics so that you do not have to move those graphics to their new levels either 

Original V7 DGN files 

It is recommended that copies of your original V7 DGN files be kept temporarily in case of 
problems that may show up after conversion to V8. Some files may have hidden corruption 
which doesn't create a problem in V7 but may prevent some elements from functioning correctly 
in V8.  When corruption is found it can usually be corrected in the original file and then be re-
converted to V8. Other situations may come up requiring re-conversion of the original V7 copy.  

A step to create folders for the original V7 DGN files is included as part of the recommended 
procedures to convert project DGN files in a batch mode.  If a V7 DGN file is converted on the 
fly by opening with V8, then the user must note or set the location where a back up copy of the 
file is placed. 

Converting by opening V7 DGN files with MicroStation V8 

If a V7 DGN file is opened with MicroStation V8 the user is prompted to convert the file but if 
you do so in this manner then the levels generated for the file may not be the correct standard 
levels. The on the fly conversion is set up to map regular non-cross section DGN files only. If 
cross section DGN files are converted in this manner then the wrong level names will be defined.  
If you have done this and need to correct the level names in the new V8 cross section DGN file 
see Re-Mapping MicroStation Level Names in this document. The recommended method of 
conversion of all DGN files is in a batch mode as described in the next section. 
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Converting Multiple V7 DGN Files to V8 Format & New Levels 1-63 

Take the following steps to convert V7 DGN files in a batch mode while applying the correct 
level names. 

1. Make sure the standard T.D.O.T. Design Division level library is downloaded to  
 C:\Program Files\Bentley\Workspace\system\dgnlib  
On the V8 web page it is the Dgnlib.exe archive file under MicroStation which includes: 

 TDOTmain.dgnlib main design file level library 
2. Make sure the standard T.D.O.T. Design Division level conversion files are downloaded 

to  
 C:\Program Files\Bentley\Workspace\system\data  
On the V8 web page it is the Data.exe archive file under MicroStation which includes: 

TDOTV8main.csv main level conversion\re-mapping file 
TDOTV8xsections.csv cross section level conversion\re-mapping file 
3. Prior to conversion …In an Windows Explorer window create new sub folders under 

your project directory named V7main and V7xsection. Move all project MicroStation 
DGN files except for cross sections and cross section sheets to the V7main  folder. Then 
move all cross sections and cross section sheet DGN files to the V7xsection folder. The 
cross section file levels 1-63 are different and so must be converted/re-mapped 
separately.  

4. Start MicroStation V8 and create a new DGN file in your project directory to work from. 
The name of the file does not matter. 

5. When MicroStation opens the DGN file go to Utilities>Batch Converter.  
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6. In the Batch Convert dialog set the Default Output Format to V8. 

7. Click on the Default Destination browse button and go your project directory where you 
wish the new V8 files to go. Click OK to set. 

 

8. Click on the Add Files or Directories to Convert icon to open the Select Files or 
Directories to Convert dialog. Go to your project folder. Click on V7main in the folder 
tree on the right and click on Add at the bottom. This adds that folder to the collection 
box at the bottom. Click on Done to return to the batch conversion dialog. 
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9. In the batch conversion dialog click on the drop down option Edit>V8 Save Options…. 
The Save As V8 Options dialog opens. 

 

10. In the Save as V8 Options dialog click on the browse button (icon to the right of CSV 
File) and go to the data folder C:\Program Files\Bentley\Workspace\system\data and 
select the conversion file TDOTV8main.csv. 

 

11. Back in the Save as V8 Options dialog make sure Apply Level Mapping is clicked on 
and then click on OK.  
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12. We are now ready to convert the files, click on the Process Batch Convert Job icon 

13. In the Files to Convert list, all files are listed with their current status which should be 
Pending. Click on the Convert button at the bottom to start the file conversions. 

 

14. When completed click on the Done button (the Convert button changes to Done when 
processing is complete). 

15. In case you need to convert these files again, in the Batch Converter dialog go to the drop 
option File>Save As and save the set ups just done in a batch conversion file in the 
default location given or perhaps in your project directory. 
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16. If you have no cross section DGN files to convert, skip to Importing Additional V8 
Settings in Batch Mode. 

17. Repeat steps 5-15 to convert cross section DGN files by accessing folder V7xsection and 
using conversion file TDOTV8xsections.csv as shown below.  If you are in the Batch 
Converter dialog you can click on the New Batch Convert Job icon to start a new set up 
for the cross sections.  
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Cross Section DGN files just prior to converting 

 

 

18. At this point all project DGN files are in V8 format and all graphics are on new V8 levels 
1-63. Files could be used as they are now but to be fully functional in V8 the steps in the 
next section should be taken to import additional V8 settings. 
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Importing Additional V8 Settings in Batch Mode 

After using MicroStation's Batch Converter for the initial conversion of the DGN files with 
levels 1-63, several additional settings need to made in order to make the files fully functional in 
V8. A vba program, V8_Import.mvba, has been developed  to delete old V7 level filters, import 
additional V8 levels & level filters, import V8 text styles, attach the new V8 color table and to 
update English working units to use Survey Feet. This program processes multiple DGN files in 
a batch mode. Immediately following the description of this program are sections describing the 
steps to add these settings manually to individual files.  

This program should not be used on un-converted V7 DGN files. If a V7 DGN file is 
encountered during processing, MicroStation alerts the user that it is a V7 DGN file and must be 
converted or opened as Read Only.  Always click on the Cancel button if this happens. 
Processing will continue on the remaining files. If the V7 DGN file is converted on the fly during 
processing the original levels 1-63 will not be set up with their correct names. 

1. Access the import program by choosing the drop down option  
TDOT > V8 – Import Additional Settings  
or from Geopak’s  D&C Manager 
Drafting Standards>Tools > V8 Import 

2. When the command is first started the Import Additional V8 Settings dialog is 
displayed.  

 

3. Under  Import Options, choose which of the V8 additional settings are desired for 
import. By default levels, level filters & text styles are turned on. Since these files have 
just been converted we need to apply all options so click the others on. 
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Notes on Updating English Working Units To Survey Feet 
The change of English working units to use survey feet is required to ensure 
compatibility with aerial survey data based on survey feet. This was not an issue in V7 
DGN files but due to changes in the way MicroStation V8 DGN files are set up it is now 
necessary. There is only a small difference between  the international foot and the US 
survey foot (1.000002  foot = 1 Survey Foot) so only large numbers such as those 
encountered with coordinate values are effected. This update will make all graphics 
reference together correctly.   

The only problem this change might create would be in the case of referencing either an 
un-converted V7 DGN file or a V8 file w/o the survey feet change to a correctly 
converted or new V8 DGN file in which case the coordinates will not line up. For this 
reason it is recommended that all DGN files to be used in MicroStation V8 should be 
converted to the new V8 format and then have their working units updated to use 
survey feet.  
When processing metric DGN files, the option to update English working units to use 
Survey Feet is ignored even if this option is clicked on since it is not required in those 
files. 

4. Use standard selection methods to highlight the DGN files to be processed. Single click 
for one file, shift key with clicks at each end for groups of files or the control key with 
clicks to pick various files. To un-select a file hold the control key down and select it 
again.  

 
Since all of the project DGN files jave just been converted and need the adduitional 
settings, use the shift key and select all of the files.   

Only files with DGN, MFC, 2D, 3D or SHT extensions from the open DGN file's folder 
are included in the file list. Any MicroStation design files with DTM graphics that use the 
old extension DTM should be renamed with a DGN extension. The DTM extension is 
ignored since InRoads surface files also use that file extension but are not MicroStation 
design files. 
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5. When files to be processed have been selected, click on the Process Files command 
button to start the import of additional settings. Each file is opened and processed.  

6. When finished a completion message is given. Click OK to dismiss the message. 

 

7. Click on the Cancel button to dismiss the dialog.  

The DGN files are now ready for use in MicroStation V8. If new graphics are to be added to the 
project DGN files which will be using the new V8 levels, skip to Updating Sheet Reference 
Levels, which describes how to update reference file attachments to show the additional new V8 
levels in sheet DGN files. 
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Adding Additional V8 levels & Level Filters – Manual Method 

It is not necessary to take these steps if Levels & Level Filters were imported using the vba 
macro, Import Additional V8 Settings.   

1. Open the DGN file in MicroStation V8 and go to Settings>Level>Manager 

 

2. In the tree on the left click on Filters which will display the filters currently in the file. 
Several old filters will probably be listed. These are from our old V7 level library and will 
not reflect all of the new levels.  

3. Right click in the area below the filter list on the right and pick option Select All. Right click 
again and pick Delete. 

 
4. In the tree on the left,  click on the DGN’s filename at the top. 
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5. Go to the drop down option Levels>Import  

Note: 
We do not use the dgnlib file as an attached library. All levels should reside in each design 
file.   

6. In the Import dialog which opens set the type at the bottom to dgn or dgnlib and browse to 
the dgnlib folder C:\Program Files\Bentley\Workspace\system\dgnlib and select the level 
library, TDOTmain.dgnlib for all DGN files. 

 

7. Click on OK to import levels and level filters. Level Manager or the Level Display dialogs 
can now be used to review levels and filters. 

 

8. Prior to leaving the DGN file click on the MicroStation drop down option 
File>Compress>Design to remove deleted elements. 
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Importing Standard Text Styles – Manual Method 

It is not necessary to take these steps if Text Styles were imported using the vba macro, Import 
Additional V8 Settings.   

1. In MicroStation go to the drop down option Element>Text Styles. The Text Styles dialog 
will open. 

 

2. In the dialog go to the drop down option Style>Import.  

In the Import dialog which opens, browse to the dgnlib folder  
C:\Program Files\Bentley\Workspace\system\dgnlib and select the dgnlib file, 
TDOTmain.dgnlib for all DGN files. 
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3. Click OK to accept the dgnlib file and all standard text styles are imported into the file and 
are listed in the Text Styles dialog. These can now be used in conjunction with the Design 
Division’s Text Style Plus tools to set text parameters prior to placement. 

 

 The Text Styles Plus tools for regular or cross section DGN files are available from the 
TDOT drop down menu, Geopak’s D&C Manager or the TDOT Design Division Toolbox. 
The key advantage to applying text styles from these tools prior to using any text placement 
function is that the correct levels and weights are set as well as the basic text parameters.  
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Attaching V8 Color Table – Manual Method 

It is not necessary to take these steps if the new color table was attached using the vba macro, 
Import Additional V8 Settings.   

1. In MicroStation go to the drop down option Settings>Color Table. The Color Table dialog 
will open. 

 

2. In the dialog go to the drop down option File>Open.  

In the Open Color Table dialog which opens, browse to the data folder  
C:\Program Files\Bentley\Workspace\system\data and select the TDOT Design Division 
standard color table, STDCOLOR.TBL. Click OK to accept the file and load it. 
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3. Back in the Color Table dialog, click Attach to apply the new colors to the DGN file. 

 

Note: 
Changes in the new V8 color table include lightening of colors 4 (dark sky blue) and 12 
(dark tan) and addition of new colors 64 (off white, urban features), 65 (blue, old color 
4), 66 (dark brown, old color 12), 67 (dark green, TDOT Logo) and 68 (light green, 
TDOT Logo). 
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Updating English Master Units to Survey Feet – Manual Method 

It is not necessary to take these steps if the master units were updated to Survey Feet using the 
vba macro, Import Additional V8 Settings.   

1. Make sure the standard T.D.O.T. Design Division unit definition file is downloaded to  
 C:\Program Files\Bentley\Workspace\system\data  
On the V8 web page it is the Data.exe archive file under MicroStation which includes: 

units.def  T.D.O.T. unit definition file with Survey Feet master unit enabled 

2. In MicroStation go to the drop down option Settings>Design File. The Design File Settings 
dialog will open. Click on the Working Units option at the bottom of the list on the left of 
the dialog. 

 

3. In the dialog click on Advanced. An Alert message is displayed warning of problems that 
might occur when storage resolution settings are changed. Click OK to proceed.  
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4. In the Advanced Unit Settings dialog, click on the per unit drop down list and change it 
from Foot to Survey Foot. The Working Areas at the bottom of the dialog will automatically 
update. Do not change any other values. Click OK to accept the change. 

 
Note: 
The previous Alert message warned about changing the length of elements when these 
settings are changed. Since 1.000002  foot (international foot) = 1 Survey Foot (US 
Survey Foot), no appreciable change in length will be applied to MicroStation elements. 

5. Back in the Design File Settings dialog, click on the Master Unit drop down list and change 
it from Feet to Survey Feet. Initially the unit label will be changed to sf. Highlight that 
setting and change it back to the single quote foot mark ' label. Click OK to accept all 
changes. 
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Updating Sheet Reference Levels 

This section describes how to update reference file attachments to show the additional new V8 
levels in sheet DGN files. This is not necessary unless new graphics are to be added which will 
be using those new levels. 

1. Open the Level Display dialog from the Primary toolbox or from the MicroStation drop 
down option Settings>Level>Display. 

 

2. In the file tree view select all of the DGN files (or whichever files need to be updated). You 
can right click in the tree area and pick the Select All option. 
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3. Change the Show control option from Levels to Filters.  

Pick the appropriate filter for the sheet.  

 

Note: 
Large scale sheets such as Property Maps have special filters for references which do not turn 
on text levels. Use these special filters on files where the text is set up at a different scale 
than that used on the sheet. 

4. Go back to Levels display and if needed adjust levels displayed for the sheet. As long as 
standard settings were used no adjustment should be necessary. 

 

5. Click on MicroStation drop down option File>Save Settings. 

6. Repeat steps 1-5 for each sheet file where reference levels need to be updated. 
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Converting V7 Cell Libraries to V8 

All standard cell libraries have been converted and upgraded for V8. If you are prompted to 
convert/upgrade a standard cell library, cancel and quit. This indicates you are using an older V7 
version of those files. Go to the Design Division’s V8 CADD web page and  download the V8 
standard cell libraries. 

This workflow is provided for guidance in converting cell libraries that users may have 
developed and used in MicroStation for their personal work. Engineers will need to use this to 
convert the cell library that contains their official seal for use on the plans. 

1. In any DGN file, go to Element>Cells and open the Cell Library dialog. 

 

2. In the Cell Library dialog go to the drop down option File>Upgrade Files to V8…. In the 
file dialog navigate to your cell library’s folder, highlight the filename and click Add to put it 
in the file collection area at the bottom. Click Done to continue. 
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3. The Upgrade Files dialog is opened and if desired you can set a backup location for your 
original file or just use the default setting. Click OK to continue. 

 

4. The Convert V7 Cell Library dialog opens and gives the user the opportunity to set the 
resolution for the cells in their library. For cells developed in standard Design Division DGN 
files this should be 1000 per Survey Foot for English cell libraries(or 10000 per Meter for 
metric). Since we used the unit Foot in V7 it will be necessary to switch to Survey Foot to 
ensure compatibility with other English V8 files. Click OK to continue. 

 

5. When the completion message box comes up click OK and you are now ready to use your 
cell library in V8. 
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Re-Mapping MicroStation V8 Level Names 

If a V7 file is converted to V8 on the fly without setting the correct standard level names or if 
level names have been altered and need to be corrected take the following steps to re-map the 
level names. 

1. Open the DGN file in question. A review of the levels using Level Manager or Level Display 
will show the current level names. In this example a V7 cross section DGN file was 
converted on the fly and has been mapped with non-cross section level names. 

 

2. Access the MicroStation drop down option File>Save As. In the dialog temporarily give the 
file a new name. Click on the Options button at the lower right of the dialog. 
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3. The Save As V8 Options dialog is opened. In the dialog click on the browse button (icon to 
the right of CSV File) and go to the data folder  
C:\Program Files\Bentley\Workspace\system\data and select the conversion file 
TDOTV8main.csv or TDOTV8xsections.csv as needed.  

 

Note: 
The conversion file TDOTV8xsections.csv is only used for level mapping cross section files 
that were developed in V7 or in V8 prior to June 2009. At that time all V8 levels were 
combined in to a single level structure. All files developed in V8 after June 2009 including 
cross section files should use the conversion file TDOTV8main.csv. 

4. Back in the Save as V8 Options dialog make sure Apply Level Mapping is clicked on and 
then click on OK. 
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5. Back in the Save As dialog click OK to create a new copy of the DGN file with the correct 
level names. The new file is automatically opened and a review of the level names will show 
their new definition. 

 

In this example of correcting an on the fly conversion of a V7 file the user would now need 
to follow through with adding the remaining V8 levels, etc. as illustrated in the previous 
section, Importing Additional V8 Settings in Batch Mode. 

6. To finish the process of correcting level names, close the DGN file, delete the old in-correct 
version of the file and then re-name the new DGN file with the original filename.   



30 

GEOPAK 
Most GEOPAK project files will work as is with no conversion needed.  

Cross section criteria files have been updated to take advantage of the new MicroStation V8 
levels and several minor fixes have been applied during the V8 development period. If further 
development of proposed cross sections is planned then you will need to update those project 
files. A MicroStation VBA has been developed to automate this process and is described in the 
next section, Updating V7 Project XS Criteria Files to V8 Versions. 

Any runs that include symbology settings for graphics may need to have the level(s) corrected as 
new graphics are produced since standard settings take advantage of the MicroStation V8 
expanded level structure. Refer to the document TDOT GEOPAK Road Course Guide.pdf for 
guidance as needed to set the appropriate levels.  

Most GEOPAK functions have not changed much and will still use your old V7 runs. Cross 
section sheet generation is the one exception to that rule since it has been completely revised in 
Geopak V8. Refer to chapter 16 in TDOT GEOPAK Road Course Guide.pdf for the new cross 
section sheet generation workflow to set up new runs. 

All standard files set up for GEOPAK have been converted for V8. If you get a message that a 
standard file needs to be converted, cancel and quit. This indicates you are using an older V7 
version of that file. Go to the Design Division’s V8 CADD web page and  download the V8 
standard files for GEOPAK. If this problem persists then you may be experiencing it due to 
software folder changes which may occur for some users who previously had MicroStation & 
GEOPAK loaded directly on C:\. Review the sections under the section, GeopakStandards 
Folder Changes for workflows to correct these situations.  
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Updating V7 Project XS Criteria Files to V8 Versions 

After the new V8 versions of the cross section criteria files have been downloaded from the web, 
this program is used to update the project cross section criteria files found in the project folder. A 
file named UpdateCriteriaFiles.bat is created in the project folder with commands to copy the 
selected files from the default criteria folder to the project folder and then this batch file is 
processed.. 

The default criteria folder is determined by the setting for the MicroStation configuration 
variable GPK_MY_CRITERIADIR. 

1. Open a DGN file from the folder where criteria files are to be updated. 

2. Access the update program by choosing the drop down option  
TDOT > Cross Sections> Update Project XS Criteria Files  
or from Geopak’s  D&C Manager 
Drafting Standards>Cross Sections > Update Criteria 

3. When the command is first started the Update Project XS Criteria Files dialog is 
displayed. 

 
4. Click on the Select All command button..  

 
5. Click on the Update Files command button. A DOS command window is briefly 

displayed during this process.  

6. Click Cancel to dismiss the dialog. 
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Cross Section Sheets 

Refer to chapter 16 in TDOT GEOPAK Road Course Guide.pdf for the new cross section 
sheet generation workflow in order to set up new runs for creating cross section sheets.  You can 
take advantage of the new standard cross section sheet libraries which make all required settings 
except for any project specific information.  

However, a method has been provided by GEOPAK to convert cross section sheet input files 
created from runs in V7 into a new cross section sheet library. This is a long process with 
limited advantages. If you choose to use this method remember the input file must be created 
while using the V7 software. See Geopak help in MicroStation J (V7) for instructions 
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Vertical Curve K values 

Since the new Geopak V8 software has just been loaded, the Vertical Alignment/Profile 
Generator tool will load the default K value table provided by Geopak. The appropriate K value 
table for T.D.O.T. Design Division projects will need to be loaded before proceeding with the 
vertical alignment design. 

 

To set the appropriate K values: 

1. Open your Geopak project and open the Profile Generator tool, Vertical Alignment on the 
Project Manager dialog. 

2. In the Profile Generator dialog go to the drop down option User>K Values. 

 



34 

3. In the K Values dialog, go to the drop down option File>Open and browse to the folder 
C:\Program Files\GeopakStandards, choose either tdot01.kvl or tdot.kvl and click OK. 

tdot01.kvl  for projects based on RD01 standard roadway drawings  
(all projects started after October 2002) 

tdot.kvl  for projects based on RD standard roadway drawings 

 

4. Back in the K Values dialog, click OK. 

5. At this point you can continue with your vertical alignment design. The current K value table 
is saved in a resource file (.rsc) used by the Profile Generator tool and will be re-loaded 
whenever the tool is used again. 
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GeopakStandards Folder Change 

The new default location for T.D.O.T. Design Division’s GeopakStandards is under 
C:\Program Files and for many users the following sections should be reviewed as this effects 
their old project data. Errors will occur when standard files cannot be found or if the V7 version 
of the file is found is incompatible with the V8 software. 

Users who already had their V7 software loaded under C:\Program Files should not experience 
these situations as long as the new V8 standard files have been downloaded to replace the older 
files for V7.  

Consultants who do not use the standard T.D.O.T. Design Division folder locations may not 
experience these problems if they maintain standard file folder locations when they switch from 
V7 to V8. If these folder locations do change with V8 then the following methods can be applied 
to correct them. 
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SMD file access in COGO 

Old Geopak projects will point to C:\GeopakStandards for the file tndot.smd. Since that file is 
now located in C:\Program Files\GeopakStandards, errors will occur when COGO is started 
since that file cannot be found.  

 

To correct this problem: 

1. In the Geopak Project Manager dialog single click on your project file (projectname.prj) and 
then go to the drop down option Projects>Edit. 

2. Click on the Preferences button in the Project Info Edit dialog. 

3. In the GEOPAK User Preferences dialog click on the Feature Preferences button. 

4. In the Feature Preferences dialog click on the Select button to specify the location of the 
SMD file as C:\Program Files\GeopakStandards\tndot.smd.  Once this is set click OK. 

5. Click on the OK button in the GEOPAK User Preferences dialog and again on the Project 
Info Edit dialog. Your project is now reset to look in the correct location. 

 

6. To take care of any new projects which you create later, go to the drop down option 
Applications>Geopak Road>User Preferences in MicroStation. Repeat steps 3 & 4 and 
click OK to accept new settings.   
 
Note:  
If step 6 is done without resetting the preferences for your project as shown in steps 1 
through 5 then everything will work correctly for the current session of Geopak but will 
revert back to the in-correct setting when the project is loaded the next time. 
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Preference file access in Superelevation Runs 

Old Geopak superelevation runs will point to C:\GeopakStandards for standard superelevation 
files.  Since these files are now located under C:\Program Files\GeopakStandards, errors will 
occur when you try to generate the super input file.  

 

To correct this problem: 

1. Open your Geopak project and open your first run under Calculate Superelevation. 

2. In the GEOPAK Automated Superelevation dialog go to the drop down option 
File>Directories. 

3. Click on the Default All button at the bottom of the settings. Preference Files Path, e Files 
Path and Length Files Path will be reset to the correct location C:\Program 
Files\GeopakStandards\. 

 

Note: 
These default directory paths are set in the configuration file TDOT.cfg which is normally 
downloaded under C:\Program Files\Bentley\Program\MicroStation\config\appl . 

4. Click on the OK button at the bottom to keep the new settings. 

5. Exit the run and click on Yes to save the changes to the run. 

6. Repeat steps 1 through 5 for each superelevation run you have.  
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Criteria file access in Proposed Cross Section Runs 

When you use the Typical function in the proposed cross section dialog the criteria files are 
copied to your project directory and those files should still be found without problems. In special 
cases you may have used the Add button to put in special criteria files from the 
C:\GeopakStandards\criteria directory which will no longer be found since those files are not 
located there. Some examples of this situation might be the use of the RetainingWall.x or Berm.x 
criteria files.  

Most of the time your proposed cross section runs will still function but your cross sections will 
leave out some portion of the proposed section, review the output screen when running proposed 
cross sections and near the top you may see the error message  
Can’t open file c:\geopakstandards\criteria\filename.x as input. 

 

or 

 

 Take the following steps to correct it: 

1. In the Proposed Cross Sections dialog go to the Shape Clusters section by clicking that 
option in the list on the left. 
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2. Click on each roadway cluster in the upper right list box and then review the criteria files 
listed below for the left and/or right sides looking for any place where the criteria file listed 
in the error message is used. In most cases these special criteria files are only used in 1 or 2 
locations and you will probably know where to look for them. 

3. When you find the criteria file use the Delete button to remove the file from your criteria list 
and be sure and note its position in the criteria list. Click Yes in the message box to confirm 
the deletion. 

4. Click on the Add button, which will open the Criteria selection dialog. 

5. Click on the directory Select button and go to  
C:\Program Files\GeopakStandards\criteria. 

6. Click on any criteria file listed and click the OK button. 

7. Back in the Criteria selection dialog scroll through the list and highlight the criteria file you 
are replacing. 

 

8. Click the To Criteria button to add it back into your criteria file list at the bottom.  

9. Finally use the Up and Down buttons to place the criteria file at the correct location in the 
list. 

10. Repeat steps 2 through 9 for any other instances of that criteria file or other criteria files not 
found. You can leave the Criteria selection dialog up during this process and if you do, close 
it, the correct directory will still be set when it is re-opened. 

11. Once these corrections are made, exit the run and click on Yes to save the changes to the run. 
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Plan Sheet Library access in Plans Sheet runs 

Old Geopak plans sheet runs will point to C:\GeopakStandards for the standard sheet library 
file tdot.psl.  Since this file is now located under C:\Program Files\GeopakStandards an error 
message box will come up when you open these runs saying that it cannot be found.  

 

To correct this problem: 

1. Open your Geopak project and open your first run under Plan & Profile Sheets. 

2. When the error message pops up saying that C:\GeopakStandards\tdot.psl is not found, 
click on the OK button to dismiss the message. 

3. In the Plan Sheet Layout dialog go to the drop down option File>Sheet Library>Attach. 

4. In the Attach Sheet Library dialog, go to C:\Program Files\GeopakStandards, choose 
tdot.psl and click OK. 

 

5. Exit the run and click on Yes to save the changes to the run. 

6. Repeat steps 1 through 5 for each plan sheet run you have.  
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Standard file access in Geopak Drainage 

Old Geopak drainage projects will point to C:\GeopakStandards & C:\Bentley… for different 
standard files. Since these files are now located under C:\Program Files…, errors will occur 
when you open your drainage project since they cannot be found.  

  

To correct this problem: 

1. Open your Geopak drainage project. You will get an error message(s) since it cannot find the 
drainage library. Click OK to dismiss the message(s). 

2. Under the Drainage drop down menu, go to the drop down option Project>Preferences. 

3. In the Preferences dialog click on the Project Components option in the list on the left. 

4. Reset the location for the Drainage Library File (DLB) by clicking on the browser icon and 
going to C:\Program Files\GeopakStandards\TDOTEnglish.dlb. 

5. Reset the location for the Drainage Cell Library by clicking on the browser icon and going 
to C:\Program Files\Bentley\Workspace\system\cell\STDS.cel. 

6. Reset the location for the Criteria Directory by clicking on the browser icon and going to 
C:\Program Files\GeopakStandards\criteria\. 

7. Reset the location for the GEOPAK DDB by clicking on the browser icon and going to 
C:\Program Files\GeopakStandards\tdot.ddb 
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8. In step 1 the software had to load the GEOPAK default drainage library in order to open your 
drainage project which automatically resets your rainfall settings. Click on Rainfall 
Parameters and reset as needed for your project. 

 

9. Click on OK to close the Preferences dialog. 

10. Under the Drainage drop down menu, go to the drop down option Project>Save to save the 
changes just made. 
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Office / MicroStation 

Very Important!  The embedded OLE Word attachments must be opened and saved as separate 
documents from MicroStation V7 before converting the design file to MicroStation V8.  The 
embedded Word document is only available from inside of MicroStation V7.  The OLE 
attachment will not be available in MicroStation V8. 

The OLE (object link and embed) attachments from MicroStation V7 files are NOT converted 
when the design file is converted to MicroStation V8.  For this reason, all of the V7 OLE Office 
97 attachments must to be linked again in the MicroStation V8 design files.    

The OLE attachments between Office 97 and MicroStation V7 were done by mapping the Office 
97 elements to MicroStation V7 graphic elements.  The procedure for attaching Office 2003 or 
2007 to MicroStation V8 is done the same, but the Office document is attached as a picture of 
the Office document.  Because the OLE attachment is different between V7 and V8, the 
formatting in the Office file needs to be different to appear correctly in MicroStation.  

For instructions on the set up of Office 2007 and detailed instructions on OLE attachments, see 
2ndSheetsV8.pdf which is available at the TDOT Design Division CADD web page in the 
Documentation section. 

Set up Office 2003  

Following are brief instructions for setting up Office 2003 when using TDOT Design Division 
Office templates linked to MicroStation V8.  These directions and some of the convert programs 
will not work correctly until these changes are made. 

1. In Word 2003, go to Tools> Options… >File Locations > User Templates and set to  
C:\Program Files\Microsoft Office\Templates  
This will set the default template location for both Word and Excel so that the TDOT 
template folders will be available when creating new documents. 

2. In Word, go to Tools> Options> Security >Macro Security…   Set the Security Level to 
Low.   

In the same menu, uncheck Make hidden markup visible when opening or saving.  

3. In Word, go to Tools> Options> Track Changes and set Use Balloons (Print and Web 
Layout): to Never. 

4. In Excel, go to Tools> Options> Security >Macro Security…   Set the Security Level to 
Low. 

5. In Excel, go to Tools> Options> Error Checking …   Click on the color  option bar and set 
the Error Indicator Color to white on lower right of color options.  

Note: The convert programs are written to access files at C:\Program Files\Microsoft 
Office\Templates\TDOT 2nd Sheets, which is the default location for the TDOT Design 
Division Office program files.  If the TDOT Office templates are not downloaded to this folder, 
these directions and program will not run correctly.   
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Convert Embedded Word OLE Attachments 

The embedded Word OLE attachments in MicroStation J V7 (version 07.01.04.10) can be 
opened only in MicroStation V7, so it is important to create a separate Office document from 
the embedded OLE attachment before upgrading MicroStation to V8. 

The following work flow goes through the process to convert 1 Word document embedded in a 
MicroStation V7 file and then to attach it in a MicroStation V8 file. In the actual process of 
converting multiple project DGN files with Word documents you may wish to repeat the 
individual steps.     

1. In MicroStation V7, open the dgn file that has the embedded Word OLE attachment. 
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2. Activate the Word OLE attachment. 
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3. In Word, go to File> Save Copy As and save to your project folder. 

 

4. Close the Word document in the design file and close MicroStation V7.  

Note: 
The embedded OLE attachment is saved in the MicroStation V8 file, but the OLE link cannot 
be accessed in V8.  If the MicroStation V8 file is saved back out as a V7 design file, the 
embedded OLE attachment will again be available to MicroStation V7.  MicroStation V7 
should be on at least one machine in each office and that machine could be used to access the 
embedded OLE Word documents in the MicroStation V7 file.  If MicroStation V7 is not 
readily available, the file can be recreated using the MicroStation V8 seed files for the V8 
index and standard drawings or notes.  This method could be just as fast depending on the 
situation. 
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5. Open the saved Word document. 

6. In Word, create a new, temporary document from the “ConvertWordToV8.dot” template. 

Go to File> New> On My Computer> TDOT 2nd Sheets> ConvertWordtoV8.dot.  

 

7. Select the macro button for the type file to be converted, Index and Standard Drawings or 
Notes.  The macro program will then list the open Word files.  Select the file to be converted.  
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8. The convert program for the index and standard drawings will search for the index area and 
prompt the user to confirm the index area as correct, define the index area or run as standard 
drawings only.  Headings are also added.  The general notes conversion program is less 
involved and simply formats the file selected. 

Note:  See the document created from the ConvertWordToV8.dot template for more details 
about converting Word documents. 

 
9. Save the converted project Word document. The Word document created from the 

ConvertWordtoV8.dot with the programs can be closed and does not need to be saved.  

10. Open the MicroStation V8 sheet file that the converted Word document will be attached to.  
Delete or move the text graphics from the MicroStation V7 OLE Word attachment.  Most of 
the text graphics will move or delete as one piece with graphic group lock on.  A fence move 
can be used to move or delete the headings text also. 

11. In the converted Word document, go to Edit> Select All, and then Edit> Copy.  This will 
put the entire document into the Windows Clipboard and make it available to MicroStation. 
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Finalizing Word Formatting: 
If blank paragraph marks were used to add space or to push the following paragraphs to the next 
column then some adjustment may be needed. Since the font has changed these will no longer 
generate the same amount of space. To make a paragraph go to the top of the next column, go to 
the drop down option Insert>Break and choose Column break from the list.  To add extra 
space between paragraphs,  highlight either one and then right click and choose the option 
Paragraph. Under the Indents and Spacing  tab, increase the Before or After values for 
Spacing. 

If  for any reason the Word file does not convert  correctly, the formatting can be done manually.  
The standard formats are as follows: 

Text styles for the Index and Standard Drawings: 
V8 Main Heading, font size14, bold, center justified 

V8 Section Headings, font size 9, bold, center justified  

V8 Index Body, font size 7,left justified, a 3.2" tab to the sheet number 

V8 Section Headings + Left, font size 9, bold, left justified 

V8 Std Dwg Body, font size 7, left justified, tab stops at .7" for the date and 1.3" for the 
description 

Text styles for General Notes: 
V8 Main Heading +_ Left, font size18, bold, left justified 

V8 Section Headings + Left, font size 9, bold, left justified 

V8 Notes Body, font size 7, a 0.32" tab to the note, numbered 1,2,3 … 

To format the text using text styles, highlight the text to be changed and select the text style 
wanted. 

Text Styles can be selected from two menus. 

1. The first menu is the Formatting toolbar. 

Open the formatting toolbar at View> Toolbars> Formatting.    

2. The second menu is the Styles and Formatting menu.   

Open this menu from Format> Styles and Formatting 
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Link Word 2003 to MicroStation V8 

MicroStation DGN seed files which include Word attachments are built by embedding the 
documents. Often when embedding Word 2003 documents, special formatting is lost. For that 
reason we recommend using a link to the Word 2003 documents as described below when re-
building project 2nd sheets in MicroStation V8.  

For instructions on embedding Word 2007 documents, see 2ndSheetsV8.pdf which is available 
at the TDOT Design Division CADD web page in the Documentation section. 

1. In MicroStation, go to Edit> Paste Special… > Linked Microsoft Office Word Document  
(The OLE attachment will be placed on the active level.) 

 

2. Select Paste as:  Link and Method:  By Corners.   

 

3. To place the document centered on the sheet, tentative snap to the upper left corner of the 
inside border of the sheet and then in the MicroStation keyin field enter dx=0.74,-0.97 (or 
dx=.019,-0.027 for metric). This sets the first corner and you are prompted to Select 
Rectangle Corner. 

4. In the MicroStation keyin field, enter dx=26 (or dx=.66 for metric). The document now 
appears on the sheet.  The dx=26 keyin yields 0.14 tall body text when plotted at a scale of 1. 

The By Corners method is used for Word documents to ensure that the text comes in at the 
correct size. The By Scale method does not yield consistent results when used with Word 
attachments. That method is used with Excel attachments. 

The second keyin given only specifies the dimension across the sheet. Depending on the 
contents of the Word document the height will vary while the width remains constant based 
on the width of the sheet in Word. 
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If smaller text sizes are acceptable or space is tight, use the keyin dx=22 for 0.12 body text 
or dx=18  for 0.10 body text. For metric jobs use dx=.56 for 0.12 or dx=.46  for 0.10. 

5. In MicroStation, use the Move Element command to re-position the attached document in 
the sheet border as needed. 

 

Notes on Word Links: 
The OLE link is displayed as a ‘picture’ of the Word document.  It is defined as a cell and has a 
shape around the edge.  The OLE link can be copied, moved or scaled using the graphics 
commands.  The OLE link is ‘view independent’, which means it will display top up for any 
view rotation. It is no longer necessary to attach and then reference to get a notes to appear 
horizontally on a rotated sheet as in the case of R.O.W. or Erosion Control notes. 

 To attach Word documents to sheets at scales other than 1, simply take the attachment 
dimension used for 1 scale sheets and multiply by the plan sheet scale.  
Example for 50 scale sheet: 26 X 50 = 1300, use keyin dx=1300. 

Dimensions used when attaching Word documents in the previous steps were based on a sheet 
size  in Word of 11” X 17”. For attaching 8 ½” X 11” sheets from Word, take the values given 
and divide by 2 since 17/8 ½ =  2. Example: 26 / 2 = 13, use keyin dx=13 
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Convert Linked Excel OLE Attachments 

In MicroStation V7: 

Before converting MicroStation V7 design files to MicroStation V8, the 2nd sheet file Excel 
attachments must be reviewed and a note made of the Excel filename and worksheet that is 
attached.  This will be the only record of what Excel workbook and worksheet is used for the 
link. 

Note:  Each Excel attachment should be reviewed to confirm that it is a linked Excel file and not 
embedded.  If the link is embedded, when the link is opened in Excel, the sheet name will say 
“Worksheet in dgn path and filename.”  If this is the case, do a File> Save Copy As … and 
save a copy of the embedded Excel file to your project folder. 
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In Excel: 

Note:  If an Excel file will not be used in the plans then the formatting does not need to be 
changed. 

1. Open the Excel files to be converted to Office / MicroStation V8 formatting.  

2. In Excel, go to File> New> On my computer… > TDOT 2nd Sheets and select the 
ConvertExcelToV8.xlt template. 

 

3. Select the macro button to Create Excel “Convert to V8” Menu.  This will create a pull 
down menu docked in the upper menu bar area at the left named Convert To V8 Menu.  
Close the ConvertExcelToV8 file created. 
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The Convert to V8 Menu will now be available in any Excel file.  When the Convert to V8 
Menu is accessed, it will open ConvertExcelToV8.xlt to run the convert programs.  
ConvertExcelToV8.xlt does not need to be saved and should be closed without saving after 
running programs.     

The Convert Menu has eight programs for use in converting Excel file formatting to Office for 
MicroStation V8.  For more detailed documentation on the programs, see the 
ConvertExcelToV8.xlt file. 

 
 

1. Convert ROW Acquisition Table -   This program lists all of the worksheets with names 
that start with ACQ.  One or more worksheets can be selected.  A backup copy is made with  
_bak on the name before any changes are made. 

 

Only the worksheets that will be linked to MicroStation V8 need to have the formatting 
changed.  The “SUR IN”  and the “DES IN” worksheets do not need to be changed.  When 
the program is run, the fonts are changed to Arial, the row and column sizes are increased and 
indents are added.  This is done so the graphical display in MicroStation V8 will have the 
correct size and appearance when linked at a scale of 17 (0.14 body text). 
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2. Convert Estimated Roadway Quantities File – This program opens a dialog box to allow 
selection of the estimate file to be converted.   

 

The program creates a new Microsoft Office Excel file by copying the information from the 
existing estimated roadway quantities excel file into a new estimated roadway quantities file.  
The existing estimated roadway quantities file is not changed.  The new file has  "_V8" in the 
filename.  This makes the new Excel formatting macros found in the estimated roadway 
quantities template available for future use. 

Excel worksheets that are not named "Col *" will be copied by sheet to the new file but no 
formatting changes will be done to the worksheet.  

Note: The Excel estimated roadway quantities file is used as an input file for the T.D.O.T. 
database program in the Program Operations Office.  The “Project Data” worksheet name 
should not be changed.  The worksheets names for the estimated roadway quantities need to 
begin with the letters “COL”. 

After converting the estimated roadway quantities file some additional cleanup may be needed. 
Use the Format Notes Area macro to trim your main quantity blocks and format its footnotes 
correctly.  

Carefully review all footnotes. The text size of the footnotes has been increased and depending 
on how footnotes were originally entered, they may be getting cut off at the end of the line or at 
the bottom of the note. If the entire note is entered in one cell, adjust the row height so that all 
lines of the note appear. If separate lines of text were entered, you can either combine the text in 
the first cell or just add any cut off words to the next line. Short, single line footnotes should not 
be affected by this.  

Prior to using the macros described next to re-format your tabulated quantities blocks, it is 
recommended that you close the original estimated roadway quantities file (without _V8 at end 
of name) to avoid picking the wrong set of worksheets for converting. 



56 

3. Select More than One Tabulated Quantities Sheets – Opens a dialog so that several 
tabulated quantity block worksheets can be selected.   

 

First option: Process Selected Worksheets 

This program converts each worksheet selected to the new Office format.  A backup copy 
of each file selected is made with  _bak on the name before any changes are made.  If no 
sheets are selected, the program ends.  This program saves each file as it is processed. 

Second option: Open New Files to Convert 

This program opens a dialog box to select Excel files to open.  After files are picked, it 
opens each file and then returns to the "Select Worksheets to be Converted" dialog box 
with all of the worksheets in all of the open Excel files listed. 

Third option: Cancel 

Exits program. 

Fourth option: Small Tab Blocks or Large Tab Blocks 

The default is Small Tab Blocks.  This will convert the worksheet from column and row 
A1 to AG65.  This covers the area of all standard tabulated quantities blocks and the area 
that will fit on a plan sheet.  If needed, the large tab block option can be selected to 
process tabulated blocks that are larger. 
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4. Convert Current Worksheet to V8 – Converts the active worksheet to V8 formatting.     

This program converts the current active worksheet to the new Excel formatting.  This 
includes changing the fonts to Arial, increasing the row heights and column widths, and 
setting indents on left and right justified cells.  No backup files are created and the file is not 
saved by the program.            

Note:  If the tab blocks do not look correct, the following macros can be used to make small 
adjustments to all columns or rows. 

5. Increase All Column Widths of Current Worksheet – Increases the column widths of the 
current active worksheet.   

6. Decrease All Column Widths of Current Worksheet - Decreases the column widths of the 
current active worksheet.   

7. Increase All Row Heights of Current Worksheet  - Increases the row heights of the current 
active worksheet.   

8. Decrease All Row Heights of Current Worksheet - Decreases the row heights of the 
current active worksheet.   

Final Tabulated Quantity Sheet Adjustments: 
To adjust column widths or row heights for individual columns or rows, click on the column 
letter or row number and then right click and choose options Column Width or Row Height to 
adjust.   

If any Sub-headings are not centered correctly, check for extra spaces at the beginning and end 
of the text. These spaces can also cause breaks to appear in block lines. If no spaces are found 
when centering appears incorrectly, highlight all cells across the area text is to be centered on 
including the cell with the text and then right click and choose the Format Cells option. Under 
the Alignment tab go to Horizontal and set to Center Across Selection. 

Save the Excel workbooks when the conversions are complete.   

If  an Excel file does not convert  correctly, the formatting can be done manually.  The standard 
formats are as follows: 

1. All fonts are Arial. 

2. Body text and footnotes are size 10, not bold. 

3. The main heading text is size 15, bold. 

4. The sub heading text and TOTALS text are size 10, bold. 

5. The body horizontal lines are light weight. 

6. The heading borders and vertical lines are medium weight. 

7. Select cells and set justification as wanted. 
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Link Excel to MicroStation V8  

1. Open the MicroStation V8 DGN sheet file with the Excel attachments.  Delete or move the 
text and graphics from the old Excel attachment.  The attachment graphics will move or 
delete as one piece with graphic group lock on.   

2. In the reformatted Excel workbook, select the block wanted, and go to Edit> Copy.  This 
will put the selected block into the Windows Clipboard and make it available to 
MicroStation.  When selecting the block in Excel, select  one column and row past the 
outside border so the display of the outside border line weight is not cut in half. 

Note: The Excel file must be saved on the users system before the OLE linking will work.  The 
Excel file should be saved to the project folder. 

3. In MicroStation, go to Edit> Paste Special… > Linked Microsoft Office Excel Worksheet 
The OLE attachment will be placed on the active level. 

 

4. Select Paste as: Link  and Method: By Size and Scale: 17 (1.4 for metric).  Use the 17  
scale for a 1-scale sheet border.  For sheet borders at other scales, multiply the 17 by the plot 
scale for the sheet border.  The body text letters should measure approximately 0.14’ and plot 
at 0.14”. 

 

Note: 
If smaller text sizes are acceptable or space is tight, use a scale of 15  for 0.12 body text or 13  
for 0.10 body text. For metric jobs use a scale of  1.2 for 0.12 or 1.0 for 0.10. 
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5. The OLE link can be moved as needed to position in the sheet border.  See 2ndSheetsV8.pdf 
for detailed instructions on OLE attachments. 

 

6. Repeat the previous steps to link other blocks from Excel into MicroStation V8 

Notes on Excel Links: 
The OLE link is displayed as a ‘picture’ of the Excel document.  It is defined as a cell and has a 
shape around the edge.  The OLE link can be copied, moved or scaled using the graphics 
commands.  The OLE link is ‘view independent’, which means it will display top up for any 
view rotation. It is no longer necessary to attach and then reference to get a block to appear 
horizontally on a rotated sheet as in the case of R.O.W. acquisition tables on some projects. 

 To attach Excel blocks to sheets at scales other than 1, simply take the attachment scale used for 
1 scale sheets and multiply by the plan sheet scale. Example for 50 scale sheet: 17 X 50 = 850. 
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Opening and Updating Office 2003 Links: 

The changes made to the Office files outside of MicroStation will not be changed in 
MicroStation until the links have either been opened or updated.   

1. To update all of the linked files, go to Edit> Update Links.  This will update all of the 
Office links in the file without opening the links. 

2. To open an Office link, use the Element Selection tool and double click the linked graphics.   

Or use the tools under Edit> Links… or Edit> Worksheet Object.  (The link must be 
selected for the Worksheet Object tools to be active.) 

Changes made in Excel will not be updated in MicroStation until the Excel file is saved and 
closed.  

Possible problem when Double Clicking Office Graphics to update:  
If the file contains macros the macro warning message will appear in the MicroStation program 
window. Click on the Enable Macros button and then if it appears to freeze up, click outside of 
MicroStation and the Office file will open.  

For instructions on opening and updating Office 2007 attachments, see 2ndSheetsV8.pdf which 
is available at the TDOT Design Division CADD web page in the Documentation section. 
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