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T.D.O.T. Design Division V8 Configurations 
for Consultant CADD\IT Managers 
1. Introduction 

Information in this document is based on the following software versions: MicroStation V8 2004 
Edition (08.05.02.35), Geopak 2004 Edition (08.05.02.35), and Office 2003 (with Office SP1). 

This document is intended as a guide for consultant CADD managers or IT personnel to use when 
setting up configurations for their personnel to apply T.D.O.T. Design Division standard files on 
their computer systems. 

Geopak’s Dependency on MicroStation 

The T.D.O.T. Design Division standard files for Geopak will not function correctly when 
downloaded by themselves. MicroStation  standard files must be downloaded as well. Those files 
contain configurations, programs and other files called by various Geopak standard files. 

. 
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2. Configuration Files 
The Design Division at T.D.O.T. uses configurations set at a default level. In other words they are 
always in place by default. Since consultants do project work for various customers this may not 
work for them. This section describes ways of dealing with this issue and shows additional 
configurations that will need to be set to maintain functionality of the standard files in the software.  

MicroStation & Geopak - TDOT.cfg 
Default settings in TDOT.cfg: 
#-----------------------------------------------------------------------------------------------------# 
# TDOT.cfg - TDOT Microstation Standards Configuration File for Microstation V8 # 
#-----------------------------------------------------------------------------------------------------# 
 
#======================================================# 
# This file sets Microstation configurations                 # 
# for TDOT's Use                         # 
# Any changes made to this file may prevent access to        # 
# TDOT's standards.                                 # 
#======================================================# 
 
# Microstation # 
 
MS_CELLLIST   < C:\Program Files\Bentley\Workspace\system\cell\STDS.CEL 
MS_CELL_SEEDFILE  < c:\program files\bentley\workspace\system\seed\English2dCell.dgn 
MS_COMPRESS_OPTIONS  = -ALL 
MS_DESIGNMODELSEED  < c:\program files\bentley\workspace\system\seed\seed2d.dgn 
MS_DESIGNSEED   = c:\program files\bentley\workspace\system\seed\seed2d.dgn 
MS_FULLPATHINTITLEBAR  = 1 
MS_PLOTDLG_DEF_PENTABLE < C:\Program Files\Bentley\Workspace\System\plotdrv\TdotPlot.tbl 
MS_REMAP_CSVFILE  < C:\Program Files\Bentley\Workspace\System\data\TDOTV8main.csv 
MS_UPDATE_KEEP_UNUSED_LIBRARY_LEVELS = 1 
MS_V7TOV8_CSVNAME  = C:\Program Files\Bentley\Workspace\System\dgnlib\TDOTV8mainOnTheFly.csv 
MS_V7_LEVEL_NAME_PREFIX = Level 
MS_PENTABLE_DATE_FORMAT=%c 
 
MS_TDOTDGNLIB_PATH  = C:\Program Files\Bentley\Workspace\System\dgnlib\ 
 
%lock MS_DESIGNSEED 
 
# Geopak # 
 
GPK_FORCE_ALLCFGVARS = 1 
 
GPK_ACBOOK_DDBFILE  < C:\Program Files\GeopakStandards\tdot.ddb 
GPK_SURVMNGR_SMDFILE  < C:\Program Files\GeopakStandards\TNDOT.smd 
GPK_VISUALPREF_SMD  < C:\Program Files\GeopakStandards\TNDOT.smd 
GPK_VISUALPREF_PLOTSCALE = 50.00000 
 
GPK_DC_3PCDIR   < C:\Program Files\GeopakStandards\3PC\ 
 
GPK_MY_CRITERIADIR   < C:\Program Files\GeopakStandards\criteria\ 
GPK_TYPICAL    < C:\Program Files\GeopakStandards\criteria\ 
GPK_TYPICAL_EDITOR   < C:\WINDOWS\system32\write.exe 
 
GPK_SUPER_PREFDIR  < C:\Program Files\GeopakStandards\ 
GPK_SUPER_EDIR   < C:\Program Files\GeopakStandards\ 
GPK_SUPER_LENGTHDIR  < C:\Program Files\GeopakStandards\ 
 
GPK_LABELER_PLANSTYLEFILE = c:\Program Files\GeopakStandards\tdotdef_plan.lsf 
GPK_LABELER_XSSTYLEFILE = c:\Program Files\GeopakStandards\tdotdef_xs.lsf 
GPK_LABELER_PROFSTYLEFILE = c:\Program Files\GeopakStandards\tdotdef_prof.lsf 
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Setting Up TDOT.cfg as a project level configuration 
Go to MicroStation Manager and in the Project field at the bottom pick New. In the Create New 
Project dialog enter the desired project name and description. Click OK to set up the project. 

. 

When a project is created, a project level configuration file is generated using the project name 
with a pcf extension. In our example this file would be named TDIOT.pcf. 

Note: Since the Design Division at T.D.O.T. uses several default search paths from MicroStation’s 
own configurations they are not set in TDOT.cfg but will need to be set in the project configuration 
file.  

Default settings in TDOT.pcf. 
#============================================================ 
# Project Configuration File - $Revision: 1.3 $   
#============================================================ 
 
_USTN_PROJECTDESCR = TDOT Design Division Project 
 
#---------------------------------------------------------------------- 
#  Set search paths. 
#---------------------------------------------------------------------- 
MS_DEF   < $(_USTN_PROJECTDATA)dgn/ 
MS_CELL   < $(_USTN_PROJECTDATA)cell/ 
MS_CELLOUT  = $(_USTN_PROJECTDATA)cell/ 
MS_CELLLIST  < $(_USTN_PROJECTDATA)cell/*.cel 
MS_CELLSELECTORDIR   = $(_USTN_PROJECTDATA)cell/ 
MS_SEEDFILES      > $(_USTN_PROJECTDATA)seed/ 
MS_SYMBRSRC  > $(_USTN_PROJECTDATA)symb/*.rsc 
MS_SETTINGSDIR       < $(_USTN_PROJECTDATA)data/ 
MS_SETTINGSOUTDIR    = $(_USTN_PROJECTDATA)data/ 
MS_DGNLIBLIST      < $(_USTN_PROJECTDATA)DGNLIB/ 
 
%lock MS_DESIGNMODELSEED 
%lock MS_SHEETMODELSEED 
%lock MS_DWGMODELSEED 
%lock MS_DESIGNSEED 

Open TDOT.cfg, copy its contents and paste them in the project configuration file at the end. 

Eliminate duplicate settings from the default project configuration file definitions. 
MS_CELLLIST  < $(_USTN_PROJECTDATA)cell/*.cel 
%lock MS_DESIGNSEED 
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Delete any you may not need.. MS_DEF is only needed if all MicroStation DGN files are to be 
kept in a single location. T.D.O.T. Design Division doesn’t use MicroStation settings files or 
multiple DGNLIB files together. The %lock function locks the current definition and should 
always be placed at the end of the file but no models other than the default model is used. 
MS_DEF   < $(_USTN_PROJECTDATA)dgn/ 
MS_SETTINGSDIR       < $(_USTN_PROJECTDATA)data/ 
MS_SETTINGSOUTDIR    = $(_USTN_PROJECTDATA)data/ 
MS_DGNLIBLIST      < $(_USTN_PROJECTDATA)DGNLIB/ 
 
%lock MS_DESIGNMODELSEED 
%lock MS_SHEETMODELSEED 
%lock MS_DWGMODELSEED 

Add additional configurations as needed. The following additions are recommended. 
MS_CUSTOMUNITDEF    unit definition file with path 
MS_DATA      data folder search path 
MS_LEVEL_LIB_DIR    data folder search path for level mapping files 
MS_MACRO     macros folder search path 
MS_MDL mdl program folder search path 
 (should only be prepended or appended) 
MS_VBASEARCHDIRECTORIES    vba program folder search path 

Reset all paths as needed for your system. This can be done simply by replacing the specified 
locations with yours or by setting up your own configuration variables for these to avoid extra 
editing later if locations change. If you use these they should be placed at the top of the file.  

Examples: 
TDOTV8 = H:/standards/tdot/microstation/v8/ 

TDOT_GPKV8 = H:/standards/tdot /geopak/v8/ 

A variable definition can contain references to other variables. References to other variables are 
made with the following syntax: 

Reference  Meaning 
$(VARIABLEREF)   Expand VARIABLEREF when this variable is used. 

${VARIABLEREF}  Expand to current value of VARIABLEREF. 

For example, consider configuration variable TDOTV8 with the definition 
"H:/standards/tdot/microstation/v8/". 

$(TDOTV8)vba/    expands to "H:/standards/tdot/microstation/v8/ vba/" 
$(TDOTV8)seed/seed2d.dgn  expands to "H:/standards/tdot/microstation/v8/ seed/seed2d.dgn " 

Use the basic guidelines described on the following page to finalize the configuration definitions in 
the project configuration file. Copy this file to the Projects folder under the MicroStation product 
directory for application at other locations. It is not necessary to define the project folder unless 
you plan to keep standard files there. 
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Basic Editing of Configuration Files (from MicroStation Help) 

Configuration variable files are text files that consist of a series of lines. Each line contains a 
configuration variable name and definition in the following syntax: 

<VARIABLENAME> <operator> <new_value> # comment 

VARIABLENAME is the name of the configuration variable defined. Nearly all variable names 
used by MicroStation begin with “MS_” or “_USTN_.” Variables whose names begin with an 
underbar ( _ ) are not displayed in the Configuration dialog box. 

Available values for operator are as follows: 

Operator Meaning 
= Assign new_value to VARIABLENAME. 

+ Append new_value to current value of VARIABLENAME. Uses a space as a 
separator. 

>  Append directory or file lists defined by new_value to a variable definition that defines 
a path. If no current value for VARIABLENAME exists, this is equivalent to the = 
operator. Otherwise, it appends a path separator character, a semicolon (;), and then 
new_value. 

<  “Prepend” directory or file lists defined by new_value (to the beginning of) a variable 
definition that defines a path. If no current value for VARIABLENAME exists, this is 
equivalent to the = operator. Otherwise, it prepends new_value followed by a path 
separator character, a semicolon (;). 

#  Anything after a # on a line is treated as a comment and is ignored. 

File path names should be entered using the forward slash (/). Windows converts all forward 
slashes (/) in new_value to backslashes (\). Also, all directory definitions should end with a trailing 
forward slash. 

This is an example of a valid directory definition: 
MS_DEF = /network/dgn/ 

When editing a configuration variable file, insert a carriage return at the end of the last line to 
ensure the entire file will be processed. Press <Enter> to insert a carriage return. 

Note:  
Through our experience at T.D.O.T., setting a literal path name with backslashes will work fine but 
should end with a backslash when setting a search path. If you plan to use a configuration variable 
in the definition you must use forward slashes.   
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Interplot Client - Iplot.cfg, Iplotsrv.cfg & ip.cfg 

These are software product level configuration files that have been customized for use by T.D.O.T. 
Design Division personnel. They are rather large files, so listed below each filename are 
configurations of particular interest that may need to be reset for your system. 

Iplot.cfg (Location: C:\Program Files\Common Files\InterPlot\IPLOT\config) 

IPLOT_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_SAVE_DIR = c:\temp 
 
IPLOT_COLOR_TABLE_PATH = "c:\program files\bentley\workspace\system\data" 
IPLOT_PEN_TABLE_PATH = "c:\program files\common files\interplot\iplot\misc" 

Iplotsrv.cfg (Location: C:\Program Files\Common Files\InterPlot\IPLOT\config) 
# IPLOTSRV_PATTERN_PATH contains the directories that will be searched 
# for the filenames specified by IPLOTSRV_PATTERN_LIB_LIST. 
 
IPLOTSRV_PATTERN_PATH = 
IPLOTSRV_PRODUCT_DIR\resrc\custom;$IPLOTSRV_PRODUCT_DIR\resrc\system 
IPLOTSRV_PATTERN_LIB_LIST = pat100.plb,100;pat300.plb,300;pat400.plb,400;pat600.plb,600 

ip.cfg (Location: C:\Program Files\InterPlot Client\config) 
IP_SETTINGS_PATH = "c:\program files\interplot client\settings" 
 
IP_DEFAULT_SETTINGS = iplot.set 
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3. Hard Coded File Paths 
Although hard coded file paths e avoided wherever possible some standard files will not function 
correctly without being set this way. The following section lists the various standard files grouped 
by software type that have hard coded file paths.   

Geopak 
DrainageProject.gdf (drainage project)  drainage library, cell library, 

criteria directory, Geopak DDB 

 
To edit: 
Start Geopak Drainage 
Go to Drainage>Project>Open 
Navigate to Geopak standards folder and open DrainageProject.gdf 
Go to Drainage>Project>Preferences 
Under Project Components make path changes as needed 
Click OK to close Preferences dialog 
Go to Drainage>Project>Save 
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Office 

ConvertExcelToV8.xlt       Excel macro & template access 

from module ConvertMenu 
subroutine CreateConvertMenu 
.OnAction =  
"C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets\ConvertExcelToV8.xlt!ProcessSelection" 

 from module ConvertEstimatetoV8 
subroutine ConvertEstToV8 
    Workbooks.Add Template:= _ 

        "C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets\EstimatedRoadwayQuantities.xlt" 

EstimatedRoadwayQuantities.xlt,      item number & description file\path 
BridgeQuantities.xlt, MaintQuantities.xlt 
from form code SearchForText 
subroutine UserForm_Initialize 
 Open "C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 

from module datfilchecks 
subroutine CheckforDat 
.LookIn = "C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets" 
    .SearchSubFolders = False 
    .Filename = "items.dat" 
    If .Execute() > 0 Then 
        datdate = FileDateTime("C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets\Items.dat") 

subroutine checkforTxt 
.LookIn = "C:\Program Files\Microsoft Office\Templates\TDOT 2nd Sheets" 
    .SearchSubFolders = False 
    .Filename = "items.dat.txt" 
    If .Execute() > 0 Then 
        txtdate = FileDateTime("C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt") 

subroutine dattxt 
FileCopy "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt",  
                "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat" 
    Kill "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt" 
Else 
    'MsgBox "dat date more recent than txt date" 
    Kill "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt" 

subroutine DateCheck 
datdate = FileDateTime("C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat") 
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subroutine TxtCopy 
FileCopy "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt",  
         "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat" 
    Kill "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\items.dat.txt" 

from module FillIn_Items 
subroutine FillinItemNos 
Open "C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat" For Input Shared As #1 

To edit: 
Open Excel template 
Go to Tools>Macro>Visual Basic Editor 
In Editor navigate to module & subroutine 
Make changes as needed 
Click Save icon in Visual Basic Editor 

Note: Due to the many instances of the same folder path in *Quantities.xlt templates a faster 
method might be to use the Replace function under Edit>Replace in the Visual Basic Editor as 
shown below. 

.  
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